aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/libibverbs/libibverbs-1.0.3.ebuild')
-rw-r--r--sys-cluster/libibverbs/libibverbs-1.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-cluster/libibverbs/libibverbs-1.0.3.ebuild b/sys-cluster/libibverbs/libibverbs-1.0.3.ebuild
new file mode 100644
index 000000000..5a44b8697
--- /dev/null
+++ b/sys-cluster/libibverbs/libibverbs-1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BSD-2 )"
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="a library that allows programs to use InfiniBand 'verbs' for direct access to IB hardware from userspace"
+SRC_URI="http://www.openfabrics.org/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.openfabrics.org/"
+
+IUSE=""
+
+DEPEND="sys-fs/sysfsutils"
+RDEPEND="${DEPEND}
+ !sys-cluster/openib-userspace"
+
+src_compile() {
+ econf || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README AUTHORS ChangeLog
+ docinto examples
+ dodoc examples/*.[ch]
+}
+