aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openib-srptools/openib-srptools-1.1.ebuild')
-rw-r--r--sys-cluster/openib-srptools/openib-srptools-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/openib-srptools/openib-srptools-1.1.ebuild b/sys-cluster/openib-srptools/openib-srptools-1.1.ebuild
new file mode 100644
index 000000000..291e02634
--- /dev/null
+++ b/sys-cluster/openib-srptools/openib-srptools-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BSD-2 )"
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="OpenIB tools for discovering and connecting to SRP CSI targets on
+InfiniBand fabrics. These targets can be accessed with the InfiniBand SRP
+initiator module, 'ib_srp,' included in Linux kernels 2.6.15 and newer."
+
+HOMEPAGE="http://www.openfabrics.org/"
+#SRC_URI="http://www.openfabrics.org/downloads/openib-userspace-${PV}.tgz"
+SRC_URI="http://mirror.gentooscience.org/openib-userspace-${PV}.tgz"
+S="${WORKDIR}/openib-userspace-${PV}/src/userspace/${PN}"
+
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ econf || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README Copying Changelog NEWS
+}
+