aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/Manifest2
-rw-r--r--sys-cluster/openmpi/openmpi-1.10.0.ebuild180
-rw-r--r--sys-cluster/openmpi/openmpi-1.10.2.ebuild180
3 files changed, 0 insertions, 362 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 7e70e85c1..70e2eed6c 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,5 +1,3 @@
-DIST openmpi-1.10.0.tar.bz2 13207009 SHA256 26b432ce8dcbad250a9787402f2c999ecb6c25695b00c9c6ee05a306c78b6490 SHA512 62966f1e8aca162040659d4f774f17b686a19a6eecd272d345eb882a88fcfe00e768316b047bfb6b1653b3d947e355266b702eba5cf0e783f799835d384a4823 WHIRLPOOL fa60102708c10c9dd07ed8d912b7f54be79246db0c6d20774c466cf749eb2b088da8a187be0a6be38fa0eb528314b0a1210ea77911ec09504c3e6cc4d532ac44
-DIST openmpi-1.10.2.tar.bz2 13349195 SHA256 8846e7e69a203db8f50af90fa037f0ba47e3f32e4c9ccdae2db22898fd4d1f59 SHA512 d34d625ef6ff98919d68f6339c5f880c6afea0d5b4caf0012bdc2dc0097038e6e2585b60f252cd2f97c811a9c936fc67a22e4037a045fe9d6ae66f3752020c8c WHIRLPOOL 59c31a3940eac4c1782669ab3bc71821182fddcb4789f136a1b8895af03cb565d7e57357a5bb6c05342adde0a5c49c3914e2ca4b8e6e203f45afb98d480f5e30
DIST openmpi-1.10.3.tar.bz2 13368112 SHA256 7484bb664312082fd12edc2445b42362089b53b17fb5fce12efd4fe452cc254d SHA512 1ddad1ffecfd07e68e891a2cfdb9d2f5baa1a91ad5286347f2884820839455c002eb4316ae62d30a4ee2efbcfe460eade7606187ea862ac4aef77ab6a2e2475d WHIRLPOOL bbe9cb0ee0ba34bab71ca10957b694d7e964b78c0efda1fff8da0361f84a8890553aad7e766f062259322dbf478918781853eb743f56ed505ff542f00a1868bd
DIST openmpi-1.6.5.tar.bz2 10943881 SHA256 fe37bab89b5ef234e0ac82dc798282c2ab08900bf564a1ec27239d3f1ad1fc85 SHA512 b0ede0264cd9263b8ba59ec51d17ad47b5f20d49d219ca05f7c396d608398d517b2023a46a2535fd6191160d709e4805c4de436dcfee56eda287383bd69f9652 WHIRLPOOL d0288677827c1deba17295ee1b69cd21da294ac314cc49404389b4c286384f9f2f229cae4c4fd62511e7f20abc510998642d6a2edfac3f16f83078f474f8e735
DIST openmpi-1.7.3.tar.bz2 12479769 SHA256 438d96c178dbf5a1bc92fa1d238a8225d87b64af26ce2a07789faaf312117e45 SHA512 a66d3b1df2a7dc76df4ffa0083919cefb0e7d4133f80bfd5c1c4bf6c5254f2a4773e3c4c9069c39b1467057c406eba3ea892d4a86030b0bd8097d12073af8ef8 WHIRLPOOL 5509f48370f5a00fee68048df5d84824fa63e528df617fc9209840f3077c2c868dbf2c3da964334e7a80c428056a5e2f9a39ddcda9967350e68222444ca918f0
diff --git a/sys-cluster/openmpi/openmpi-1.10.0.ebuild b/sys-cluster/openmpi/openmpi-1.10.0.ebuild
deleted file mode 100644
index 6879645be..000000000
--- a/sys-cluster/openmpi/openmpi-1.10.0.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit cuda eutils flag-o-matic fortran-2 java-pkg-opt-2 multilib mpi toolchain-funcs versionator
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-IUSE_OPENMPI_FABRICS="
- openmpi_fabrics_ofed
- openmpi_fabrics_knem
- openmpi_fabrics_psm"
-
-IUSE_OPENMPI_RM="
- openmpi_rm_pbs
- openmpi_rm_slurm"
-
-IUSE_OPENMPI_OFED_FEATURES="
- openmpi_ofed_features_control-hdr-padding
- openmpi_ofed_features_connectx-xrc
- openmpi_ofed_features_udcm
- openmpi_ofed_features_rdmacm
- openmpi_ofed_features_dynamic-sl
- openmpi_ofed_features_failover"
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
-IUSE="cma cuda +cxx elibc_FreeBSD fortran heterogeneous ipv6 java mpi-threads numa romio threads vt
- ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
-
-REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
- openmpi_rm_pbs? ( !openmpi_rm_slurm )
- openmpi_fabrics_psm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_connectx-xrc? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_failover? ( openmpi_fabrics_ofed )"
-
-MPI_UNCLASSED_DEP_STR="
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )"
-
-CDEPEND="
- dev-libs/libevent
- dev-libs/libltdl:0
- >=sys-apps/hwloc-1.9.1[numa?]
- sys-libs/zlib
- cuda? ( dev-util/nvidia-cuda-toolkit )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- openmpi_fabrics_ofed? ( sys-fabric/ofed:* )
- openmpi_fabrics_knem? ( sys-cluster/knem )
- openmpi_fabrics_psm? ( sys-fabric/infinipath-psm:* )
- openmpi_rm_pbs? ( sys-cluster/torque )
- openmpi_rm_slurm? ( sys-cluster/slurm )
- openmpi_ofed_features_rdmacm? ( sys-fabric/librdmacm:* )
- $(mpi_imp_deplist)"
-
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.6 )"
-
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.6 )"
-
-pkg_setup() {
- fortran-2_pkg_setup
- java-pkg-opt-2_pkg_setup
- MPI_ESELECT_FILE="eselect.mpi.openmpi"
-
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --with-hwloc="${EPREFIX}/usr"
- --with-libltdl="${EPREFIX}/usr"
- )
-
- if use fortran; then
- myconf+=(--enable-mpi-fortran=all)
- else
- myconf+=(--enable-mpi-fortran=no)
- fi
-
- if use java; then
- # We must always build with the right -source and -target
- # flags. Passing flags to javac isn't explicitly supported here
- # but we can cheat by overriding the configure test for javac.
- export ac_cv_path_JAVAC="$(java-pkg_get-javac) $(java-pkg_javac-args)"
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf $(mpi_econf_args) "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_with cma) \
- $(use_with cuda cuda "${EPREFIX}"/opt/cuda) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_enable ipv6) \
- $(use_enable java) \
- $(use_enable java mpi-java) \
- $(use_enable mpi-threads mpi-thread-multiple) \
- $(use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
- $(use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr) \
- $(use_with openmpi_fabrics_psm psm "${EPREFIX}"/usr) \
- $(use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding) \
- $(use_enable openmpi_ofed_features_connectx-xrc openib-connectx-xrc) \
- $(use_enable openmpi_ofed_features_rdmacm openib-rdmacm) \
- $(use_enable openmpi_ofed_features_udcm openib-udcm) \
- $(use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl) \
- $(use_enable openmpi_ofed_features_failover btl-openib-failover) \
- $(use_with openmpi_rm_pbs tm) \
- $(use_with openmpi_rm_slurm slurm)
-}
-
-src_install () {
- default
-
- # From USE=vt see #359917
- rm "${ED}"/$(mpi_root)/usr/share/libtool &> /dev/null
-
- # Avoid collisions with libevent
- rm -rf "${ED}"/$(mpi_root)/usr/include/event2 &> /dev/null
-
- # Remove la files, no static libs are installed and we have pkg-config
- find "${ED}"/$(mpi_root)/usr/$(get_libdir)/ -type f -name '*.la' -delete
-
- if use java; then
- local mpi_jar="${ED}"/$(mpi_root)/usr/$(get_libdir)/mpi.jar
- java-pkg_dojar "${mpi_jar}"
- # We don't want to install the jar file twice
- # so let's clean after ourselves.
- rm "${mpi_jar}" || die
- fi
-
- mpi_dodoc README AUTHORS NEWS VERSION
- mpi_imp_add_eselect
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- emake -j1 check
-}
diff --git a/sys-cluster/openmpi/openmpi-1.10.2.ebuild b/sys-cluster/openmpi/openmpi-1.10.2.ebuild
deleted file mode 100644
index 6879645be..000000000
--- a/sys-cluster/openmpi/openmpi-1.10.2.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit cuda eutils flag-o-matic fortran-2 java-pkg-opt-2 multilib mpi toolchain-funcs versionator
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-IUSE_OPENMPI_FABRICS="
- openmpi_fabrics_ofed
- openmpi_fabrics_knem
- openmpi_fabrics_psm"
-
-IUSE_OPENMPI_RM="
- openmpi_rm_pbs
- openmpi_rm_slurm"
-
-IUSE_OPENMPI_OFED_FEATURES="
- openmpi_ofed_features_control-hdr-padding
- openmpi_ofed_features_connectx-xrc
- openmpi_ofed_features_udcm
- openmpi_ofed_features_rdmacm
- openmpi_ofed_features_dynamic-sl
- openmpi_ofed_features_failover"
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
-IUSE="cma cuda +cxx elibc_FreeBSD fortran heterogeneous ipv6 java mpi-threads numa romio threads vt
- ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
-
-REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
- openmpi_rm_pbs? ( !openmpi_rm_slurm )
- openmpi_fabrics_psm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_connectx-xrc? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )
- openmpi_ofed_features_failover? ( openmpi_fabrics_ofed )"
-
-MPI_UNCLASSED_DEP_STR="
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )"
-
-CDEPEND="
- dev-libs/libevent
- dev-libs/libltdl:0
- >=sys-apps/hwloc-1.9.1[numa?]
- sys-libs/zlib
- cuda? ( dev-util/nvidia-cuda-toolkit )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- openmpi_fabrics_ofed? ( sys-fabric/ofed:* )
- openmpi_fabrics_knem? ( sys-cluster/knem )
- openmpi_fabrics_psm? ( sys-fabric/infinipath-psm:* )
- openmpi_rm_pbs? ( sys-cluster/torque )
- openmpi_rm_slurm? ( sys-cluster/slurm )
- openmpi_ofed_features_rdmacm? ( sys-fabric/librdmacm:* )
- $(mpi_imp_deplist)"
-
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.6 )"
-
-DEPEND="${CDEPEND}
- java? ( >=virtual/jdk-1.6 )"
-
-pkg_setup() {
- fortran-2_pkg_setup
- java-pkg-opt-2_pkg_setup
- MPI_ESELECT_FILE="eselect.mpi.openmpi"
-
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --with-hwloc="${EPREFIX}/usr"
- --with-libltdl="${EPREFIX}/usr"
- )
-
- if use fortran; then
- myconf+=(--enable-mpi-fortran=all)
- else
- myconf+=(--enable-mpi-fortran=no)
- fi
-
- if use java; then
- # We must always build with the right -source and -target
- # flags. Passing flags to javac isn't explicitly supported here
- # but we can cheat by overriding the configure test for javac.
- export ac_cv_path_JAVAC="$(java-pkg_get-javac) $(java-pkg_javac-args)"
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf $(mpi_econf_args) "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_with cma) \
- $(use_with cuda cuda "${EPREFIX}"/opt/cuda) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_enable ipv6) \
- $(use_enable java) \
- $(use_enable java mpi-java) \
- $(use_enable mpi-threads mpi-thread-multiple) \
- $(use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
- $(use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr) \
- $(use_with openmpi_fabrics_psm psm "${EPREFIX}"/usr) \
- $(use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding) \
- $(use_enable openmpi_ofed_features_connectx-xrc openib-connectx-xrc) \
- $(use_enable openmpi_ofed_features_rdmacm openib-rdmacm) \
- $(use_enable openmpi_ofed_features_udcm openib-udcm) \
- $(use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl) \
- $(use_enable openmpi_ofed_features_failover btl-openib-failover) \
- $(use_with openmpi_rm_pbs tm) \
- $(use_with openmpi_rm_slurm slurm)
-}
-
-src_install () {
- default
-
- # From USE=vt see #359917
- rm "${ED}"/$(mpi_root)/usr/share/libtool &> /dev/null
-
- # Avoid collisions with libevent
- rm -rf "${ED}"/$(mpi_root)/usr/include/event2 &> /dev/null
-
- # Remove la files, no static libs are installed and we have pkg-config
- find "${ED}"/$(mpi_root)/usr/$(get_libdir)/ -type f -name '*.la' -delete
-
- if use java; then
- local mpi_jar="${ED}"/$(mpi_root)/usr/$(get_libdir)/mpi.jar
- java-pkg_dojar "${mpi_jar}"
- # We don't want to install the jar file twice
- # so let's clean after ourselves.
- rm "${mpi_jar}" || die
- fi
-
- mpi_dodoc README AUTHORS NEWS VERSION
- mpi_imp_add_eselect
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- emake -j1 check
-}