aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/ittapi/ittapi-3.23.0.ebuild')
-rw-r--r--sys-devel/ittapi/ittapi-3.23.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/ittapi/ittapi-3.23.0.ebuild b/sys-devel/ittapi/ittapi-3.23.0.ebuild
new file mode 100644
index 000000000..38ae1b432
--- /dev/null
+++ b/sys-devel/ittapi/ittapi-3.23.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Instrumentation and Tracing Technology and Just-In-Time API "
+HOMEPAGE="https://github.com/intel/ittapi"
+SRC_URI="https://github.com/intel/ittapi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ # Make it a shared library
+ sed -i -e 's/STATIC/SHARED/g' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}/bin/"*.so
+ doheader -r "${S}/include/"*
+ einstalldocs
+}