aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/blas')
-rw-r--r--virtual/blas/blas-2.1-r1.ebuild38
-rw-r--r--virtual/blas/blas-2.1-r2.ebuild41
-rw-r--r--virtual/blas/blas-2.1-r3.ebuild11
-rw-r--r--virtual/blas/metadata.xml6
4 files changed, 9 insertions, 87 deletions
diff --git a/virtual/blas/blas-2.1-r1.ebuild b/virtual/blas/blas-2.1-r1.ebuild
deleted file mode 100644
index 7b846bd31..000000000
--- a/virtual/blas/blas-2.1-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib
-
-DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="
- || (
- >=sci-libs/blas-reference-20110417
- >=dev-cpp/eigen-3.1.2
- sci-libs/atlas[fortran]
- sci-libs/openblas
- >=sci-libs/acml-4.4
- sci-libs/gotoblas2
- >=sci-libs/mkl-10.3
- )
- doc? ( >=app-doc/blas-docs-3.2 )"
-DEPEND=""
-
-pkg_pretend() {
- if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
- ewarn "You have still the old ${PN} library symlink present"
- ewarn "Please delete"
- ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
- ewarn "to avoid problems with new ${PN} structure"
- fi
-}
diff --git a/virtual/blas/blas-2.1-r2.ebuild b/virtual/blas/blas-2.1-r2.ebuild
deleted file mode 100644
index b7380d082..000000000
--- a/virtual/blas/blas-2.1-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib
-
-DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc int64"
-
-RDEPEND="
- int64? (
- sci-libs/openblas[int64]
- )
- || (
- >=sci-libs/blas-reference-20110417
- >=dev-cpp/eigen-3.1.2
- sci-libs/atlas[fortran]
- sci-libs/openblas[int64?]
- >=sci-libs/acml-4.4
- sci-libs/gotoblas2
- >=sci-libs/mkl-10.3
- )
- doc? ( >=app-doc/blas-docs-3.2 )"
-DEPEND=""
-
-pkg_pretend() {
- if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
- ewarn "You have still the old ${PN} library symlink present"
- ewarn "Please delete"
- ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
- ewarn "to avoid problems with new ${PN} structure"
- fi
-}
diff --git a/virtual/blas/blas-2.1-r3.ebuild b/virtual/blas/blas-2.1-r3.ebuild
index 8c83e5309..48f4d0e8c 100644
--- a/virtual/blas/blas-2.1-r3.ebuild
+++ b/virtual/blas/blas-2.1-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit multilib
+inherit multilib-build
DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
HOMEPAGE=""
@@ -18,15 +18,15 @@ IUSE="doc int64"
RDEPEND="
int64? (
|| (
- >=sci-libs/openblas-0.2.11[int64]
- >=sci-libs/blas-reference-20131116-r1[int64]
+ sci-libs/blas-reference[int64,${MULTILIB_USEDEP}]
+ >=sci-libs/openblas-0.2.11[int64,${MULTILIB_USEDEP}]
)
)
|| (
- >=sci-libs/blas-reference-20131116-r1[int64?]
+ sci-libs/blas-reference[int64?,${MULTILIB_USEDEP}]
+ >=sci-libs/openblas-0.2.11[int64?,${MULTILIB_USEDEP}]
>=dev-cpp/eigen-3.1.4
sci-libs/atlas[fortran]
- >=sci-libs/openblas-0.2.11[int64?]
>=sci-libs/acml-4.4
sci-libs/gotoblas2
>=sci-libs/mkl-10.3
@@ -40,5 +40,6 @@ pkg_pretend() {
ewarn "Please delete"
ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
ewarn "to avoid problems with new ${PN} structure"
+ die "Old lib${PN} detected"
fi
}
diff --git a/virtual/blas/metadata.xml b/virtual/blas/metadata.xml
index a27bb5a01..cc94dad69 100644
--- a/virtual/blas/metadata.xml
+++ b/virtual/blas/metadata.xml
@@ -6,8 +6,8 @@
Gentoo virtual package for the Basic Linear Algebra Subprograms
FORTRAN 77 implementation.
</longdescription>
-<use>
- <flag name="int64">Add eselect module for blas libraries built with 64 bits
+ <use>
+ <flag name="int64">Add eselect module for blas libraries built with 64 bits
integer ABI</flag>
-</use>
+ </use>
</pkgmetadata>