summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-05-27 07:08:41 +0000
committerMichał Górny <mgorny@gentoo.org>2011-05-27 07:08:41 +0000
commit2d28335f798dcc6e9f08235f7bb037c3ba3b45d8 (patch)
treedc8dc1ebb78c00b415523a79ee273a6d2b7d1459 /dev-python/eggtranslations/eggtranslations-1.2.1.ebuild
parentdev-python/django-haystack: EAPI bump. (diff)
downloadsunrise-reviewed-2d28335f798dcc6e9f08235f7bb037c3ba3b45d8.tar.gz
sunrise-reviewed-2d28335f798dcc6e9f08235f7bb037c3ba3b45d8.tar.bz2
sunrise-reviewed-2d28335f798dcc6e9f08235f7bb037c3ba3b45d8.zip
dev-python/eggtranslations: Version bump, EAPI bump, support Python ABIs, fix distutils eclass use.
(Portage version: 2.2.0_alpha35/git/Linux x86_64, signed Manifest commit with key 42B9401D) svn path=/sunrise/; revision=12095
Diffstat (limited to 'dev-python/eggtranslations/eggtranslations-1.2.1.ebuild')
-rw-r--r--dev-python/eggtranslations/eggtranslations-1.2.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/eggtranslations/eggtranslations-1.2.1.ebuild b/dev-python/eggtranslations/eggtranslations-1.2.1.ebuild
new file mode 100644
index 000000000..ebb16a9f6
--- /dev/null
+++ b/dev-python/eggtranslations/eggtranslations-1.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND='2'
+RESTRICT_PYTHON_ABIS='3.*'
+
+inherit distutils
+
+MY_PN="EggTranslations"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides an API for accessing localizations and resources packaged in python eggs"
+HOMEPAGE="http://chandlerproject.org/Projects/EggTranslations"
+SRC_URI="mirror://pypi/E/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/epydoc )"
+RDEPEND="dev-python/configobj"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README.txt"
+
+DISTUTILS_SRC_TEST=setup.py
+
+src_compile() {
+ if use doc; then
+ epydoc --html --verbose --url="${HOMEPAGE}" --name="${MY_P}" egg_translations.py \
+ || die "Making the docs failed!"
+ fi
+ distutils_src_compile
+}
+
+src_install() {
+ if use doc; then
+ dohtml html/* || die "Installing the docs failed!"
+ fi
+ distutils_src_install
+}