summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2011-12-26 21:50:50 +0000
committerJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2011-12-26 21:50:50 +0000
commit2330e9e07cf522dfddd2cc1409e22865b1fe8487 (patch)
tree9240a8a5cf2ebefe687e2c51909613b3a46b5a9b /dev-python/pottymouth/files
parentdev-python/bottle: Version bump (diff)
downloadsunrise-reviewed-2330e9e07cf522dfddd2cc1409e22865b1fe8487.tar.gz
sunrise-reviewed-2330e9e07cf522dfddd2cc1409e22865b1fe8487.tar.bz2
sunrise-reviewed-2330e9e07cf522dfddd2cc1409e22865b1fe8487.zip
dev-python/pottymouth: Version bump. Drop old patch
svn path=/sunrise/; revision=12605
Diffstat (limited to 'dev-python/pottymouth/files')
-rw-r--r--dev-python/pottymouth/files/pottymouth-2.1.0-fix-setup.patch77
-rw-r--r--dev-python/pottymouth/files/pottymouth-2.1.2-fix-setup.patch15
2 files changed, 15 insertions, 77 deletions
diff --git a/dev-python/pottymouth/files/pottymouth-2.1.0-fix-setup.patch b/dev-python/pottymouth/files/pottymouth-2.1.0-fix-setup.patch
deleted file mode 100644
index b861dc46c..000000000
--- a/dev-python/pottymouth/files/pottymouth-2.1.0-fix-setup.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 9efac65..1024568 100755
---- a/setup.py
-+++ b/setup.py
-@@ -1,49 +1,31 @@
--#!/usr/bin/env python
--
--try:
-- from setuptools import setup
--except ImportError:
-- from distutils.core import setup
-+from distutils.core import setup
- from pottymouth import __version__
-
- import os
- import os.path
- import shutil
-
--external_files = ('readme.html', 'LICENSE.txt')
--for f in external_files:
-- shutil.copy(os.path.join('..', f), f)
--
--try:
-- setup(name='PottyMouth',
-- py_modules=['pottymouth'],
-- version=__version__,
-- data_files=[('share/doc/python-pottymouth', ['readme.html',
-- 'LICENSE.txt',
-- 'test.py' ,
-- 'web.py' ,
-- 'profile.py' ,]),],
-- # metadata for fun
-- author='Matt Chisholm',
-- author_email='matt@theory.org',
-- description="transform unstructured, untrusted text to safe, valid XHTML",
-- license='BSD License',
-- keywords='wiki',
-- url='http://glyphobet.net/pottymouth',
-- download_url='http://glyphobet.net/pottymouth/dist/',
-- long_description="""PottyMouth transforms completely unstructured and untrusted text to valid, nice-looking, completely safe XHTML.
-+setup(name='PottyMouth',
-+ py_modules=['pottymouth'],
-+ version=__version__,
-+ # metadata for fun
-+ author='Matt Chisholm',
-+ author_email='matt@theory.org',
-+ description="transform unstructured, untrusted text to safe, valid XHTML",
-+ license='BSD License',
-+ keywords='wiki',
-+ url='http://glyphobet.net/pottymouth',
-+ download_url='http://glyphobet.net/pottymouth/dist/',
-+ long_description="""PottyMouth transforms completely unstructured and untrusted text to valid, nice-looking, completely safe XHTML.
-
- PottyMouth is designed to handle input text from non-technical, potentially careless or malicious users. It produces HTML that is completely safe, programmatically and visually, to include on any web page. And you don't need to make your users read any instructions before they start typing. They don't even need to know that PottyMouth is being used.""",
-- classifiers=['Development Status :: 5 - Production/Stable',
-- 'Intended Audience :: Developers',
-- 'License :: OSI Approved :: BSD License',
-- 'Operating System :: OS Independent',
-- 'Environment :: Web Environment',
-- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: Message Boards',
-- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: News/Diary',
-- ],
-- platforms='All',
-- )
--finally:
-- for f in external_files:
-- os.unlink(f)
-+ classifiers=['Development Status :: 5 - Production/Stable',
-+ 'Intended Audience :: Developers',
-+ 'License :: OSI Approved :: BSD License',
-+ 'Operating System :: OS Independent',
-+ 'Environment :: Web Environment',
-+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: Message Boards',
-+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: News/Diary',
-+ ],
-+ platforms='All',
-+ )
diff --git a/dev-python/pottymouth/files/pottymouth-2.1.2-fix-setup.patch b/dev-python/pottymouth/files/pottymouth-2.1.2-fix-setup.patch
new file mode 100644
index 000000000..716a0898d
--- /dev/null
+++ b/dev-python/pottymouth/files/pottymouth-2.1.2-fix-setup.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.py b/setup.py
+index 180f378..4c39292 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,6 @@
+ #!/usr/bin/env python
+
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+ from pottymouth import __version__
+
+ import os