summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Smith (gaurdro) <gaurdro@gmail.com>2011-03-16 14:26:56 +0000
committerRoss Smith (gaurdro) <gaurdro@gmail.com>2011-03-16 14:26:56 +0000
commit66e159f2aa728e2ff343da227c44e0477f442965 (patch)
treedf48c4ce5f7a21016ca28a71ed42c7ed55ed241c /sci-chemistry
parentsci-chemistry/hoomd: Fixed unescaped characters in pkg_setup (diff)
downloadsunrise-reviewed-66e159f2aa728e2ff343da227c44e0477f442965.tar.gz
sunrise-reviewed-66e159f2aa728e2ff343da227c44e0477f442965.tar.bz2
sunrise-reviewed-66e159f2aa728e2ff343da227c44e0477f442965.zip
sci-chemistry/hoomd: new ebuild for bug 357021, thanks Tommy[D], mgorny and the rest of the sunrise devs
svn path=/sunrise/; revision=11824
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/hoomd/ChangeLog4
-rw-r--r--sci-chemistry/hoomd/Manifest3
-rw-r--r--sci-chemistry/hoomd/hoomd-9999.ebuild108
3 files changed, 114 insertions, 1 deletions
diff --git a/sci-chemistry/hoomd/ChangeLog b/sci-chemistry/hoomd/ChangeLog
index 492f7e729..7ae6f63b2 100644
--- a/sci-chemistry/hoomd/ChangeLog
+++ b/sci-chemistry/hoomd/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Mar 2011; Ross Smith (gaurdro) <gaurdro@gmail.com> +hoomd-9999.ebuild:
+ new ebuild for bug 357021, thanks Tommy[D], mgorny and the rest of the
+ sunrise devs
+
15 Mar 2011; Ross Smith (gaurdro) <gaurdro@gmail.com>
hoomd-0.9.1.3815.ebuild:
Fixed unescaped characters in pkg_setup
diff --git a/sci-chemistry/hoomd/Manifest b/sci-chemistry/hoomd/Manifest
index dd741e722..ef9623689 100644
--- a/sci-chemistry/hoomd/Manifest
+++ b/sci-chemistry/hoomd/Manifest
@@ -2,5 +2,6 @@ DIST hoomd-0.9.1.3815.tar.bz2 4631180 RMD160 ba2f16ae7802a8c612fd44cd353bccd1b52
DIST hoomd-devdoc-0.9.1.tar.bz2 729365 RMD160 e214c7351adbf32d7512ca8f9d0d7d2bc8753403 SHA1 511eb112d28297c0e0a0d3c4525934c54bc704ef SHA256 e2d5fcad50c94b7a7eea1b7142f4d0c7590a014587e6c8978c74e81580b8e57e
DIST hoomd-userdoc-0.9.1.pdf 1462069 RMD160 db125732309cbdc85f6233fbefb246158a257820 SHA1 395439b3377d275b974831b00067ac046e94ab25 SHA256 119d97d630df30683debf4e128b3b4692bb3926b14ada3d4da7117a8c1086b09
EBUILD hoomd-0.9.1.3815.ebuild 3256 RMD160 9b67873b9efc7fe5dffd07422dc76302603f623d SHA1 ba6ababa90cc3880ecd11473ee81f96a8bc473b0 SHA256 1532e4db267f1fa3c7cc3f656e928d6128b487cd024ed5e67f58bb4a357d094d
-MISC ChangeLog 593 RMD160 4705425e6b167d87676c5022aa829e6facc9ec70 SHA1 42ae9d863d7ea2fb0705f8a522a4ae0f3333fdc4 SHA256 72660e3d53e5de5dd67543532cd945718cd1db1d54f1bfd6d25c9db8556ecf2e
+EBUILD hoomd-9999.ebuild 3280 RMD160 9092fe61bad4bf5e4de65fd12b8875e25d709ec7 SHA1 2133994998c8906df58081e54128f886ec27a9fd SHA256 3c4dd920299622e0bfbf938003e6b003b2dd41a291bb154f315ec80f41e284f9
+MISC ChangeLog 758 RMD160 69ade1666489b21da2b51179ff2e9a1aaee3cf6c SHA1 9ad32b8618e9a23f1ce35a83eeb1c1643cc59a13 SHA256 f63f2ef3f32521b8943e9e92f7f1093b4b811d5e9a5723b57806bc7ec568a800
MISC metadata.xml 519 RMD160 9d8f1a598d95942c3832bb3f37c1cf15bde68bfa SHA1 3b646121e743776d9c2f7d5762cec79d67cdae16 SHA256 0274214dbdc5912f598acd525ebb28d0c54c01b23d21182bb31e12bb1e09c7b0
diff --git a/sci-chemistry/hoomd/hoomd-9999.ebuild b/sci-chemistry/hoomd/hoomd-9999.ebuild
new file mode 100644
index 000000000..72e73c5e7
--- /dev/null
+++ b/sci-chemistry/hoomd/hoomd-9999.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+ESVN_REPO_URI=http://codeblue.umich.edu/hoomd-blue/svn/trunk
+MY_DOC_PV="0.9.1"
+
+inherit cmake-utils eutils fdo-mime python subversion versionator
+DESCRIPTION="HOOMD performs general purpose molecular dynamics simulations on NVIDIA GPUs"
+HOMEPAGE="http://codeblue.umich.edu/hoomd-blue/index.html"
+SRC_URI="doc? ( http://codeblue.umich.edu/hoomd-blue/downloads/0.9/hoomd-userdoc-${MY_DOC_PV}.pdf
+ http://codeblue.umich.edu/hoomd-blue/downloads/0.9/hoomd-devdoc-${MY_DOC_PV}.tar.bz2 )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="+cuda debug doc +openmp +single-precision static-libs zlib"
+
+RDEPEND="dev-libs/boost
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-2.0 dev-util/nvidia-cuda-sdk )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+pkg_setup() {
+ python_pkg_setup
+
+ if use cuda; then
+ if has_version '<=dev-util/nvidia-cuda-toolkit-3.0'; then
+ if version_is_at_least 4.4 $(gcc-version); then
+ ewarn "Nvidia CUDA SDK version 3.0 and below requires a gcc version less than 4.4"
+ ewarn "Enabling the cuda use flag with gcc version 4.4 or higher will cause build failures in those SDK versions."
+ ewarn "Please use gcc-config to set a gcc version less than 4.4 ."
+ fi
+
+ elif has_version '<=dev-util/nvidia-cuda-toolkit-3.2'; then
+ if version_is_at_least 4.5 $(gcc-version); then
+ ewarn "Nvidia CUDA SDK Version 3.2 and below require a gcc version less than 4.5"
+ ewarn "Enabling the cuda use flag with gcc version 4.5 or higher will cause build failures in those SDK versions."
+ ewarn "Please use gcc-config to set a gcc version less than 4.5."
+ fi
+ fi
+ fi
+}
+
+src_prepare(){
+ python_copy_sources
+}
+
+src_configure(){
+ use single-precision && local sp="ON" || local sp="OFF"
+
+ if use !single-precision && use cuda ; then
+ ewarn "Single precision must be enabled to have cuda support built-in."
+ ewarn "Single-precision will be enabled for this build."
+ local sp="ON"
+ fi
+ my_config() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable cuda CUDA)
+ $(cmake-utils_use_enable static-libs STATIC)
+ $(cmake-utils_use_enable test BUILD_TESTING)
+ $(cmake-utils_use_enable openmp OPENMP)
+ $(cmake-utils_use_enable zlib ZLIB)
+ -DENABLE_VALGRIND=OFF
+ -DENABLE_NATIVE_INSTALL=0N
+ -DENABLE_DOXYGEN=OFF
+ -DPYTHON_SITEDIR="$(python_get_sitedir)"
+ -DENABLE_SINGLE_PRECISION=${sp}
+ -DCMAKE_BUILD_TYPE=${cbt}
+ -DENABLE_OCELOT:BOOL=OFF
+ )
+
+ cmake-utils_src_configure
+ }
+
+ python_execute_function -s my_config
+}
+
+src_test(){
+ python_execute_function -s cmake-utils_src_test
+}
+
+src_install(){
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ newins "${DISTDIR}/hoomd-userdoc-${MY_DOC_PV}.pdf" hoom-userdoc-${PV}.pdf || die "docs failed"
+
+ insinto /usr/share/doc/${PF}/devdocs
+ mv "${WORKDIR}/hoomd-devdoc-${MY_DOC_PV}/" "${WORKDIR}/hoomd-devdoc-${PV}" || die
+ doins -r "${WORKDIR}/hoomd-devdoc-${PV}/" || die "docs failed"
+ fi
+
+ python_execute_function -s cmake-utils_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}