summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Szymaniak <lazy_bum@o2.pl>2011-06-26 21:30:11 +0000
committerPiotr Szymaniak <lazy_bum@o2.pl>2011-06-26 21:30:11 +0000
commit1fcd2573b9deb341e4d557dbf75dbc8826a6153a (patch)
tree3ee28d86df10519bba0f9bebd221c049850b83ca /sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
parentAdded gcc-4.6 patch, moved to EAPI=4, lots of other small fixes. (diff)
downloadsunrise-reviewed-1fcd2573b9deb341e4d557dbf75dbc8826a6153a.tar.gz
sunrise-reviewed-1fcd2573b9deb341e4d557dbf75dbc8826a6153a.tar.bz2
sunrise-reviewed-1fcd2573b9deb341e4d557dbf75dbc8826a6153a.zip
sys-auth/pam_pgsql: Updated to new EAPI, added gcc-4.6 patch.
svn path=/sunrise/; revision=12160
Diffstat (limited to 'sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild')
-rw-r--r--sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild b/sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
index 6eb6fe84b..acb539b75 100644
--- a/sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
+++ b/sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+
inherit pam
DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
@@ -18,7 +20,11 @@ DEPEND=">=sys-libs/pam-0.78-r3
dev-db/postgresql-base"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN/_/-}"
+S=${WORKDIR}/${PN/_/-}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
+}
src_install() {
insinto /etc