summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang Frisch (xororand) <xororand@frexx.de>2007-06-28 00:43:16 +0000
committerWolfgang Frisch (xororand) <xororand@frexx.de>2007-06-28 00:43:16 +0000
commit079a404ad6a62f13bdd73937e27c0c57a20226e8 (patch)
tree993e4957005ab953ebef7d55e518ca04e6ad4e39
parentgames-fps/uhexen2-cvs: Version bump (and drop old) (diff)
downloadsunrise-079a404ad6a62f13bdd73937e27c0c57a20226e8.tar.gz
sunrise-079a404ad6a62f13bdd73937e27c0c57a20226e8.tar.bz2
sunrise-079a404ad6a62f13bdd73937e27c0c57a20226e8.zip
app-admin/collectd: New ebuild for bug 107076
svn path=/sunrise/; revision=4075
-rw-r--r--app-admin/collectd/ChangeLog9
-rw-r--r--app-admin/collectd/Manifest6
-rw-r--r--app-admin/collectd/collectd-4.0.4.ebuild60
-rw-r--r--app-admin/collectd/files/collectd-4.0.4.confd16
-rw-r--r--app-admin/collectd/files/collectd-4.0.4.initd29
-rw-r--r--app-admin/collectd/metadata.xml5
6 files changed, 125 insertions, 0 deletions
diff --git a/app-admin/collectd/ChangeLog b/app-admin/collectd/ChangeLog
new file mode 100644
index 000000000..ffd3a2df9
--- /dev/null
+++ b/app-admin/collectd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/collectd
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 28 Jun 2007; Wolfgang Frisch (xororand) <xororand@frexx.de>
+ +collectd-4.0.4.ebuild, +files/collectd-4.0.4.confd,
+ +files/collectd-4.0.4.initd, +metadata.xml:
+ New ebuild for bug 107076
+
diff --git a/app-admin/collectd/Manifest b/app-admin/collectd/Manifest
new file mode 100644
index 000000000..42008303c
--- /dev/null
+++ b/app-admin/collectd/Manifest
@@ -0,0 +1,6 @@
+AUX collectd-4.0.4.confd 529 RMD160 52920082294789ed9b46d2db37ae85a697587070 SHA1 5993dc1aa3a1a51464ffe84b2f3133c343253739 SHA256 93841388cdc88bc9cc8916a33892191e7cb1ce5557f76051d5b65ef0ea4cc558
+AUX collectd-4.0.4.initd 655 RMD160 e6386b437fb6175cf35e3207a16a938341e70513 SHA1 5c9684f94b95ef1a835cdc0402003ec9966d2e96 SHA256 642c8463dfa0c49b71b9e145b2913ae59371b43f4dd6671c1701fa03b0b3140c
+DIST collectd-4.0.4.tar.bz2 709151 RMD160 656d56ec5c13274f6b2af4f6ebb655db9cadcf09 SHA1 cf9b22ab588927cbda42031ec5bc0ee3e655cc22 SHA256 ad2f27ecc52b0f3a7bc9717e903a81223767184a4e18a04a5de7245639855afa
+EBUILD collectd-4.0.4.ebuild 1422 RMD160 f1fec459a41e54fc44ce9b716c0be79ef2f3f37a SHA1 76087b6ef5ad6141e62c3990faf112e0ae123a26 SHA256 8ef1baba5f57fb2aa0d13015db1c87caad385885dd3f3fade0f1932cd7a15ee0
+MISC ChangeLog 311 RMD160 9167e69016b7db4ff8210522e06dcdd7b9090754 SHA1 ab74d4893a01337dd3486b45903da0b143bca456 SHA256 3e1c88b7c584bc34e41022bb7538af1ac455fb573f268e09bf7d7c8d4b06d446
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-admin/collectd/collectd-4.0.4.ebuild b/app-admin/collectd/collectd-4.0.4.ebuild
new file mode 100644
index 000000000..11e997970
--- /dev/null
+++ b/app-admin/collectd/collectd-4.0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A small daemon to collect system statistics into RRD files."
+HOMEPAGE="http://collectd.org"
+SRC_URI="http://collectd.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="lm_sensors hddtemp mysql perl"
+
+DEPEND="
+ net-misc/curl
+ >=net-analyzer/rrdtool-1.2
+ hddtemp? ( app-admin/hddtemp )
+ lm_sensors? ( >=sys-apps/lm_sensors-2.9.0 )
+ mysql? ( >=dev-db/mysql-4.1 )"
+
+src_compile() {
+ local myconf="
+ --prefix=/usr
+ --mandir=/usr/share/man
+ --infodir=/usr/share/info
+ --datadir=/usr/share
+ --sysconfdir=/etc
+ --localstatedir=/var
+ $(use_enable lm_sensors sensors)
+ $(use_enable mysql)
+ $(use_enable perl)"
+ econf $myconf
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die install failed
+
+ dodoc AUTHORS ChangeLog README NEWS TODO
+
+ docinto contrib
+ dodoc contrib/*
+
+ keepdir /var/lib/collectd
+
+ newinitd ${FILESDIR}/${P}.initd collectd
+ newconfd ${FILESDIR}/${P}.confd collectd
+
+ insinto /etc
+ newins ${FILESDIR}/${P}.conf collectd.conf
+}
+
+pkg_postinst() {
+ einfo "collectd introduced some changes in the new 4.x series."
+ einfo "For further information, read http://collectd.org/migrate-v3-v4.shtml"
+ einfo "The migration script can be found at:"
+ einfo "/usr/share/doc/${P}/contrib/migrate-3-4.px.bz2"
+}
diff --git a/app-admin/collectd/files/collectd-4.0.4.confd b/app-admin/collectd/files/collectd-4.0.4.confd
new file mode 100644
index 000000000..bfc40dbd8
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.0.4.confd
@@ -0,0 +1,16 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Nice value used to launch collectd, to change priority of the process. As
+# you usually will want to run it in background, a default of 5 is used.
+#
+
+#COLLECTD_NICELVL='5'
+# Location of configuration file. Modify if you don't like the standard one.
+#
+#COLLECTD_CFGFILE='/etc/collectd.conf'
+
+# File used to store the PID file. Usually you won't need to touch it.
+#
+#COLLECTD_PIDFILE='/var/run/collectd.pid'
diff --git a/app-admin/collectd/files/collectd-4.0.4.initd b/app-admin/collectd/files/collectd-4.0.4.initd
new file mode 100644
index 000000000..913269daf
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.0.4.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+: ${COLLECTD_PIDFILE:='/var/run/collectd.pid'}
+: ${COLLECTD_CFGFILE:='/etc/collectd.conf'}
+: ${COLLECTD_NICELVL:='5'}
+
+
+depend() {
+ :
+}
+
+start() {
+ ebegin "Starting collectd"
+ start-stop-daemon --start --quiet \
+ --nicelevel "${COLLECTD_NICELVL}" --exec /usr/sbin/collectd -- \
+ -P "${COLLECTD_PIDFILE}" -C "${COLLECTD_CFGFILE}"
+ eend $? "Failed to start collectd"
+}
+
+stop() {
+ ebegin "Stopping collectd"
+ start-stop-daemon --stop --quiet \
+ --pidfile "${COLLECTD_PIDFILE}"
+ eend $? "Failed to stop collectd"
+}
+
diff --git a/app-admin/collectd/metadata.xml b/app-admin/collectd/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-admin/collectd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>