summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-29 00:11:36 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-29 00:11:36 +0000
commit18959f7f7b69e4a96264513552d3aaaaef1d43f8 (patch)
tree0c296212537bff4b0a8e80c9a015214472554b14
parentx11-misc/spacefm-cdemu-plugin: New Ebuild for bug 410083 thanks to xmw and fl... (diff)
downloadsunrise-18959f7f7b69e4a96264513552d3aaaaef1d43f8.tar.gz
sunrise-18959f7f7b69e4a96264513552d3aaaaef1d43f8.tar.bz2
sunrise-18959f7f7b69e4a96264513552d3aaaaef1d43f8.zip
x11-misc/spacefm-dmenu-plugin: New Ebuild for bug 410083 thanks to xmw and floppym
svn path=/sunrise/; revision=12855
-rw-r--r--x11-misc/spacefm-dmenu-plugin/ChangeLog10
-rw-r--r--x11-misc/spacefm-dmenu-plugin/Manifest4
-rw-r--r--x11-misc/spacefm-dmenu-plugin/metadata.xml7
-rw-r--r--x11-misc/spacefm-dmenu-plugin/spacefm-dmenu-plugin-0.5.ebuild41
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/spacefm-dmenu-plugin/ChangeLog b/x11-misc/spacefm-dmenu-plugin/ChangeLog
new file mode 100644
index 000000000..8ad91abeb
--- /dev/null
+++ b/x11-misc/spacefm-dmenu-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/spacefm-dmenu-plugin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*spacefm-dmenu-plugin-0.5 (29 Mar 2012)
+
+ 29 Mar 2012; hasufell <julian.ospald@googlemail.com>
+ +spacefm-dmenu-plugin-0.5.ebuild, +metadata.xml:
+ New Ebuild for bug 410083 thanks to xmw and floppym
+
diff --git a/x11-misc/spacefm-dmenu-plugin/Manifest b/x11-misc/spacefm-dmenu-plugin/Manifest
new file mode 100644
index 000000000..da7e7fe67
--- /dev/null
+++ b/x11-misc/spacefm-dmenu-plugin/Manifest
@@ -0,0 +1,4 @@
+DIST Open-with_v0.5.spacefm-plugin.tar.gz 14166 RMD160 8e76e22dfa2e982895043ae7c78b00d59e70498d SHA1 fb362186cab6993fdf53ea922355a97af8287551 SHA256 32c2fb38d0ec0fcd55ec7be771df58fa35068f87e8101c1f95c907695c4274e6
+EBUILD spacefm-dmenu-plugin-0.5.ebuild 1187 RMD160 c5742b26faad3911f56f1c1ebe06a4055c39f9f1 SHA1 ecc0e9f2c868a579a6c4872ae7d7f00c72bc2310 SHA256 5e607e95767f018a873f7435b1640ddfea49576b94caa70d9d5e47b7e53e11ef
+MISC ChangeLog 332 RMD160 40e3fd70ec5aba7650dbdb8cce40ae1699156007 SHA1 a5f85a99d52e35ea3ac97747817fedb2aa1b9f3d SHA256 2d3170a6d96b4986055ef348afe890dd595b6f02513b12697c78a6044b13f753
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/x11-misc/spacefm-dmenu-plugin/metadata.xml b/x11-misc/spacefm-dmenu-plugin/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/x11-misc/spacefm-dmenu-plugin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/spacefm-dmenu-plugin/spacefm-dmenu-plugin-0.5.ebuild b/x11-misc/spacefm-dmenu-plugin/spacefm-dmenu-plugin-0.5.ebuild
new file mode 100644
index 000000000..ac69b4eb0
--- /dev/null
+++ b/x11-misc/spacefm-dmenu-plugin/spacefm-dmenu-plugin-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Allows user to open files with any command in the user's \$PATH via dmenu"
+HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
+SRC_URI="http://bashscripts.googlecode.com/files/Open-with_v${PV}.spacefm-plugin.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/dmenu
+ x11-misc/spacefm"
+
+src_install() {
+ find -name COPYING -delete
+ insinto /usr/share/spacefm/plugins/dmenu
+ doins -r cstm_* plugin
+ insinto /usr/share/spacefm/plugin-files
+ doins "${DISTDIR}"/Open-with_v${PV}.spacefm-plugin.tar.gz
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "You might need to restart spacefm for the changes to take effect."
+ einfo ""
+ elog "If you want to add a plugin to a different menu via design-mode"
+ elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo ""
+ elog "If you have copied the plugin to a different menu using the"
+ elog "design mode you might want to remove it from there as well."
+ einfo ""
+}