summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2009-11-03 18:19:58 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2009-11-03 18:19:58 +0000
commit191adb6f622eea51abb7fd5a0a557144146d004d (patch)
treed3db60e6d19cc8dcc09a2b16d41cadadb6369a05
parentapp-editors/gummi: Version bump for Gummi (diff)
downloadsunrise-191adb6f622eea51abb7fd5a0a557144146d004d.tar.gz
sunrise-191adb6f622eea51abb7fd5a0a557144146d004d.tar.bz2
sunrise-191adb6f622eea51abb7fd5a0a557144146d004d.zip
media-radio/wspr: New ebuild for bug 291186. Thanks Tommy[D] for thorough review and help.
svn path=/sunrise/; revision=9453
-rw-r--r--media-radio/wspr/ChangeLog8
-rw-r--r--media-radio/wspr/Manifest4
-rw-r--r--media-radio/wspr/metadata.xml5
-rw-r--r--media-radio/wspr/wspr-1.12.ebuild64
4 files changed, 81 insertions, 0 deletions
diff --git a/media-radio/wspr/ChangeLog b/media-radio/wspr/ChangeLog
new file mode 100644
index 000000000..0ed374914
--- /dev/null
+++ b/media-radio/wspr/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-radio/wspr
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 03 Nov 2009; Thomas Beierlein (TomJBE) <tb@forth-ev.de> +wspr-1.12.ebuild,
+ +metadata.xml:
+ New ebuild for bug 291186. Thanks Tommy[D] for thorough review and help.
+
diff --git a/media-radio/wspr/Manifest b/media-radio/wspr/Manifest
new file mode 100644
index 000000000..521727287
--- /dev/null
+++ b/media-radio/wspr/Manifest
@@ -0,0 +1,4 @@
+DIST wspr-1.12.tgz 1133691 RMD160 b3829be5b816d456e541e79fe211e941efd4427c SHA1 39d3bed90d1ff3cb349f07af04a1df3bd82b8aec SHA256 170e590e99305df8f45fb3bf6fe331799ee59041e2718300281ffa77cdd00718
+EBUILD wspr-1.12.ebuild 1596 RMD160 b0e0b6ab50fba2b4b1f00bfe5d598f1cea0a6cf6 SHA1 e551558ad429ee2c8f2bab56a81aaa3b78514395 SHA256 28661772926eae137f6d1187dbe74a768ef3fc0cabaa5357bc2459b6f6fd11ff
+MISC ChangeLog 287 RMD160 0d640c906606a381828157f8855d190cd04ec016 SHA1 ea40d9f4950696f1df8f13c24f7f178f60ac1680 SHA256 9e7c777ac38f27424ad15124e3b9ba2d5e472d9f7d25a61d77d4a102e0a89797
+MISC metadata.xml 175 RMD160 721d3e9edeca5ec248d3c5ad4d0c9ae12b215fc3 SHA1 eb3a66d933b7ebc2dc0ca2de9441a4fe261dfac3 SHA256 4ae19a73fff18bc637ee689aac906bf8492e451de50c7458d896c76c1e619588
diff --git a/media-radio/wspr/metadata.xml b/media-radio/wspr/metadata.xml
new file mode 100644
index 000000000..54be98542
--- /dev/null
+++ b/media-radio/wspr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted-herd</herd>
+</pkgmetadata>
diff --git a/media-radio/wspr/wspr-1.12.ebuild b/media-radio/wspr/wspr-1.12.ebuild
new file mode 100644
index 000000000..882d1b780
--- /dev/null
+++ b/media-radio/wspr/wspr-1.12.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools distutils flag-o-matic multilib python
+
+DESCRIPTION="Weak Signal Propagation Reporter"
+HOMEPAGE="http://www.physics.princeton.edu/pulsar/K1JT/wspr.html"
+SRC_URI="http://www.physics.princeton.edu/pulsar/K1JT/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+
+RDEPEND="
+ dev-lang/python[tk]
+ dev-python/numpy
+ dev-python/imaging[tk]
+ dev-python/pmw
+ media-libs/portaudio
+ media-libs/libsamplerate"
+DEPEND="${RDEPEND}"
+
+S="${S}/src"
+
+src_prepare() {
+ python_version
+
+ # fix a 64 bit bug
+ sed -i -e "s/size_t \*length0/int \*length0/g" nhash.c || die "sed failed"
+
+ # upstream confused LIBDIRS with LDFLAGS in Makefile. f2py wants only
+ # LIBDIRS as parameter and takes LDFLAGS only from environment.
+ sed -i \
+ -e "s/@LDFLAGS@/@LIBDIRS@/" \
+ -e "s/LDFLAGS/LIBDIRS/g" \
+ -e "s/\${RM} -rf/\#\${RM} -rf/" Makefile.in || die "sed failed"
+
+ # drop hardcoded libdir path,
+ # switch LDFLAGS naming to LIBDIRS (see above comment).
+ sed -i -e "s/, f2py/, f2py${PYVER}/" \
+ -e "s:-L/usr/local/lib \${LDFLAGS}:-L/usr/$(get_libdir):" \
+ -e "s/(Makefile)/(Makefile setup.py)/" \
+ -e "s/LDFLAGS/LIBDIRS/g" \
+ configure.ac || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ # -shared is neded by f2py but cannot be set earlier as configure does
+ # not like it
+ append-ldflags -shared
+ emake || die "emake failed."
+}
+
+src_install() {
+ distutils_src_install
+ dobin wspr || die "dobin failed"
+ dodoc BUGS WSPR_*.TXT || die "dodoc failed"
+}