summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2008-10-22 19:03:48 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2008-10-22 19:03:48 +0000
commit237dadf13bd614da66a0de48ea94926001af2cb9 (patch)
treef293d3ac1d7e3ca88a180b515afe1286c07ac731
parentnet-misc/netgo_ng: Version Bump (diff)
downloadsunrise-237dadf13bd614da66a0de48ea94926001af2cb9.tar.gz
sunrise-237dadf13bd614da66a0de48ea94926001af2cb9.tar.bz2
sunrise-237dadf13bd614da66a0de48ea94926001af2cb9.zip
dev-cpp/opensaml: New ebuild wrt bug 202952. Tnx to original bug authors.
svn path=/sunrise/; revision=7249
-rw-r--r--dev-cpp/opensaml/ChangeLog8
-rw-r--r--dev-cpp/opensaml/Manifest4
-rw-r--r--dev-cpp/opensaml/metadata.xml8
-rw-r--r--dev-cpp/opensaml/opensaml-1.1.1.ebuild35
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/opensaml/ChangeLog b/dev-cpp/opensaml/ChangeLog
new file mode 100644
index 000000000..3986e1a22
--- /dev/null
+++ b/dev-cpp/opensaml/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-cpp/opensaml
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 22 Oct 2008; Thomas Beierlein (TomJBE) <tb@forth-ev.de>
+ +opensaml-1.1.1.ebuild, +metadata.xml:
+ New ebuild wrt bug 202952. Tnx to original bug authors.
+
diff --git a/dev-cpp/opensaml/Manifest b/dev-cpp/opensaml/Manifest
new file mode 100644
index 000000000..134bd9817
--- /dev/null
+++ b/dev-cpp/opensaml/Manifest
@@ -0,0 +1,4 @@
+DIST opensaml-1.1.1.tar.gz 438888 RMD160 d146527fb0bbbbadb3f33cb581ebe88eacdac7a1 SHA1 cd712bac1e77b8d597395d9e988af65154e46854 SHA256 207af6ad74bfd7ca7ec345c36e1c6507428807b111f0f90661e669b014a047f1
+EBUILD opensaml-1.1.1.ebuild 774 RMD160 2a2f31bd0046b1de3686377b3920d726e38f1236 SHA1 73241c3ec329499e17ff91712518973918e28f8e SHA256 62fd7c80b668eab390f5f2b46d3cd1dcd5fe9518b6cd1fa9a8fe32f459966934
+MISC ChangeLog 275 RMD160 a3127c2997e9237479b3aea64cdc67fc53522e60 SHA1 1267019774fe671adcdf4b867c6e0a5d57d05ba1 SHA256 c9bdc4863747bd3ef430ed223a5c1fefdcab856ac91c243e9afeaeb53aa3722d
+MISC metadata.xml 326 RMD160 4b4bc32e1b0914d0e87678eccb5c1cc5caca4de2 SHA1 aa14453224e7e6adc1a02c26f06b92ec18579f2d SHA256 7bde9bee36a363e3316fb42afde960f7af0899e9afda2cc540bb3fd12b899b23
diff --git a/dev-cpp/opensaml/metadata.xml b/dev-cpp/opensaml/metadata.xml
new file mode 100644
index 000000000..fcb1a6510
--- /dev/null
+++ b/dev-cpp/opensaml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>OpenSAML is a set of open source C++ libraries
+ for working with the Security Assertion Markup Language (SAML).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/opensaml/opensaml-1.1.1.ebuild b/dev-cpp/opensaml/opensaml-1.1.1.ebuild
new file mode 100644
index 000000000..bc6673267
--- /dev/null
+++ b/dev-cpp/opensaml/opensaml-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION="Open Source Security Assertion Markup Language implementation"
+HOMEPAGE="http://www.opensaml.org/"
+SRC_URI="http://shibboleth.internet2.edu/downloads/${PN}/cpp/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ net-misc/curl
+ dev-libs/log4shib
+ dev-libs/xerces-c
+ >=dev-libs/xml-security-c-1.3.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # make documentation location Gentoo like
+ epatch "${FILESDIR}"/opensaml_doc.diff
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc doc/NEWS.txt doc/NOTICE.txt doc/README.txt
+}