summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bilitch <hs@gentoo.org>2009-05-17 15:19:54 +0000
committerPeter Bilitch <hs@gentoo.org>2009-05-17 15:19:54 +0000
commit2cd635d69e5a9c0060265bd39076df9de49bd1d7 (patch)
treeb75850a5e61b28ded89f5efcedbd6468fe071ba3
parentdev-db/pgbouncer: New init script and fixes to the ebuild to reflect this. Al... (diff)
downloadsunrise-2cd635d69e5a9c0060265bd39076df9de49bd1d7.tar.gz
sunrise-2cd635d69e5a9c0060265bd39076df9de49bd1d7.tar.bz2
sunrise-2cd635d69e5a9c0060265bd39076df9de49bd1d7.zip
games-fps/prey: New ebuild for bug 270050, reviewed mainly by Tommy[D]
svn path=/sunrise/; revision=8557
-rw-r--r--games-fps/prey/ChangeLog8
-rw-r--r--games-fps/prey/Manifest4
-rw-r--r--games-fps/prey/metadata.xml5
-rw-r--r--games-fps/prey/prey-20090219.ebuild113
4 files changed, 130 insertions, 0 deletions
diff --git a/games-fps/prey/ChangeLog b/games-fps/prey/ChangeLog
new file mode 100644
index 000000000..adc55ceda
--- /dev/null
+++ b/games-fps/prey/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/prey
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 17 May 2009; Robert Cernansky (HS) <openhs@users.sourceforge.net>
+ +prey-20090219.ebuild, +metadata.xml:
+ New ebuild for bug 270050, reviewed mainly by Tommy[D]
+
diff --git a/games-fps/prey/Manifest b/games-fps/prey/Manifest
new file mode 100644
index 000000000..d6de1b142
--- /dev/null
+++ b/games-fps/prey/Manifest
@@ -0,0 +1,4 @@
+DIST prey-installer-02192009.bin 45447932 RMD160 cb962c9a1742172849c152b854ef3a2f5e91cf95 SHA1 300b72a613fa996b955b7f64c313067a0b0ddfb2 SHA256 b3d06fc51afbb5dc88d7e0f9d5267cd9d171edf9d18c84c5f66c8172da74b357
+EBUILD prey-20090219.ebuild 2691 RMD160 8569336c81858beb129cc55eba50fc4907fd7903 SHA1 51317f963fe79e41904027dedeb89a662b86a990 SHA256 81e75401a07155e71f686b99734dda48900eb79b9153078c935557e2f050a825
+MISC ChangeLog 281 RMD160 1683e3bc1b4d290f3a84f4378fed54320317f243 SHA1 dac8aa95f90eb829733a278e7e976df1257c5668 SHA256 5453935aff689337790ead3c86d64e18a5d0da2eb9ebe818950537289536f6e3
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-fps/prey/metadata.xml b/games-fps/prey/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-fps/prey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/games-fps/prey/prey-20090219.ebuild b/games-fps/prey/prey-20090219.ebuild
new file mode 100644
index 000000000..eb04c174f
--- /dev/null
+++ b/games-fps/prey/prey-20090219.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="First person shooter from 3D Realms"
+HOMEPAGE="http://icculus.org/prey/ http://www.3drealms.com/prey/"
+UPSTREAM_PV=${PV:4:2}${PV:6}${PV::4}
+SRC_URI="http://icculus.org/prey/downloads/prey-installer-${UPSTREAM_PV}.bin"
+
+LICENSE="PREY"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cdinstall dedicated openal opengl"
+PROPERTIES="interactive"
+
+# mirror restriction might be needed as well
+RESTRICT="strip"
+
+UIDEPEND="virtual/opengl
+ openal? ( x86? ( media-libs/openal )
+ amd64? ( app-emulation/emul-linux-x86-sdl ) )"
+DEPEND="app-arch/unzip"
+RDEPEND="
+ opengl? ( ${UIDEPEND} )
+ !dedicated? ( !opengl? ( ${UIDEPEND} ) )
+ cdinstall? ( games-fps/prey-data )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_TEXTRELS="${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbsv.so"
+
+
+pkg_setup() {
+ games_pkg_setup
+
+ # This is a binary x86 package => ABI=x86
+ has_multilib_profile && ABI="x86"
+}
+
+
+src_unpack() {
+ unzip "${DISTDIR}/prey-installer-${UPSTREAM_PV}.bin"
+}
+
+
+src_install() {
+
+ # installation of files that goes to ${dir}
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ # >common (both dedicated and graphical client) files
+ doins -r data/punkbuster-linux-x86/pb || die "doins punkbuster"
+
+ # >graphical game client files
+ if use opengl || ! use dedicated ; then
+ doexe data/prey-linux-x86/prey{,.x86} \
+ data/prey-linux-x86/libNvidiaVidMemTest.so || \
+ die "doexe client executables"
+
+ dosym "/usr/$(get_libdir)/libSDL-1.2.so.0" "${dir}" || \
+ die "dosym libSDL"
+
+ if use openal; then
+ dosym "/usr/$(get_libdir)/libopenal.so" "${dir}/openal.so" || \
+ die "dosym libopenal"
+ fi
+
+ newicon data/prey-linux-data/prey.png ${PN}.png
+
+ games_make_wrapper ${PN} ./prey "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Prey"
+ fi
+
+ # >dedicated server files
+ if use dedicated ; then
+ doexe data/prey-linux-x86/preyded{,.x86} || \
+ die "doexe dedicated executables"
+
+ games_make_wrapper ${PN}-ded ./preyded "${dir}" "${dir}"
+ fi
+
+ # installation of files that goes to ${dir}/base
+ insinto "${dir}/base"
+ exeinto "${dir}/base"
+ doexe data/prey-linux-x86/base/gamex86.so || die "doexe base/gamex86.so"
+ doins -r data/prey-linux-data/base/* || die "doins data"
+
+ # documentation files
+ dodoc data/prey_readme.txt || die "dodoc readme"
+
+ prepgamesdirs
+}
+
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall ; then
+ elog "You need to copy pak000.pk4 through pak004.pk4 from either your"
+ elog "installation media or your hard drive to ${dir}/base before"
+ elog "running the game."
+ echo
+ fi
+}