summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stahn <michael.stahn.42@gmail.com>2013-03-25 20:06:49 +0100
committerMichael Stahn <michael.stahn.42@gmail.com>2013-03-25 20:06:49 +0100
commit5927ecbe07a51bb09f0f00502cc5d9a129e1b19f (patch)
tree0c7af1c8241c6359a824d7135c0a2d19027ae058
parentgames-fps/assaultcube: add server useflag description (diff)
downloadsunrise-5927ecbe07a51bb09f0f00502cc5d9a129e1b19f.tar.gz
sunrise-5927ecbe07a51bb09f0f00502cc5d9a129e1b19f.tar.bz2
sunrise-5927ecbe07a51bb09f0f00502cc5d9a129e1b19f.zip
dev-python/pypacker: New Ebuild for bug #458922
-rw-r--r--dev-python/pypacker/ChangeLog10
-rw-r--r--dev-python/pypacker/Manifest4
-rw-r--r--dev-python/pypacker/metadata.xml5
-rw-r--r--dev-python/pypacker/pypacker-1.9.ebuild35
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pypacker/ChangeLog b/dev-python/pypacker/ChangeLog
new file mode 100644
index 000000000..c676496c0
--- /dev/null
+++ b/dev-python/pypacker/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pypacker
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pypacker-1.9 (25 Mar 2013)
+
+ 25 Mar 2013; Michael Stahn (mike) <michael.stahn.42@gmail.com>
+ +pypacker-1.9.ebuild, +metadata.xml:
+ New Ebuild for bug #458922
+
diff --git a/dev-python/pypacker/Manifest b/dev-python/pypacker/Manifest
new file mode 100644
index 000000000..7860ae404
--- /dev/null
+++ b/dev-python/pypacker/Manifest
@@ -0,0 +1,4 @@
+DIST pypacker-1.9.tar.gz 139846 SHA256 37154082dcfe933d258abf134e11b64bd4ccf39912496411a2abc5eb191f0b39 SHA512 3a1f89bb2eb720c0674af0e60eafe77076036928b3202262d6e394780251a29f4770918c0127ffa06a2ba31d06265631430d15a8358389e65ce6354e34c887d3 WHIRLPOOL 192ce9a6737fbd079609f089c6a3a8206d58904452afa9b94309b5abb7386f8620c9a19a074b6244fe7034dce2249b762ef46d045218f18c12040ed74b3b6f0c
+EBUILD pypacker-1.9.ebuild 768 SHA256 6e203625a6e91c0399e2ed56c110b07537bc847bbe8a49e30b771139fbe482e3 SHA512 3c600ba6458968ba7013fddb9f1e71f4ef1326dbb82d9d271298ad30f6ecf4cc3da9cd00f6c72fea179236df4259c15e4f283df193ede9aff6b168757f8ea2e9 WHIRLPOOL de0d69740cf1dc98ea3dc7a513222db6881c14be3485ec284e0a3745a73e440a0b64615958db8f22c94996dc00ea45c098895660ed18870db182c67cd62528e3
+MISC ChangeLog 283 SHA256 b6c2e40495937146a74c98da982ee6c47a2f43ff349b6ac04b1f5d3f48a19b5b SHA512 55552f393835f16d7bacca5962d727f3b64eade4b6903df76274f69c3c307c34e769a68ac61b18fa974c3fa32297d977715d48f486972e2bd37770511812a560 WHIRLPOOL b00eb05eba21c0d9a4916ca525e139b3c7d9364b384996e412d55debbc537a507edefcefeb7162c896b8461576c9ea715767f9bb45d1cd1d912196ef31dacc19
+MISC metadata.xml 208 SHA256 c4841c87f0c2b9b5e679a27dc72180be8d508fb3f5df0fbab2ec2c805c0a6d82 SHA512 21d90d4547c76c80e50e134359dfbec42b158bbc16e4741738bdde5f67b7926d158dae1905948a477405b74e754ce4ed63cad910f220a709db8dfccf160e5288 WHIRLPOOL 33ec53f42c7a8c4c419989bd94e083c417574463e19c9c1322e6b96d0f5a6a52e3dd69fbedf2d11a7a77d24a93b81f3a604b6b33cac62548389537bf3e42df0e
diff --git a/dev-python/pypacker/metadata.xml b/dev-python/pypacker/metadata.xml
new file mode 100644
index 000000000..31dc017fa
--- /dev/null
+++ b/dev-python/pypacker/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/pypacker/pypacker-1.9.ebuild b/dev-python/pypacker/pypacker-1.9.ebuild
new file mode 100644
index 000000000..787442b48
--- /dev/null
+++ b/dev-python/pypacker/pypacker-1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creating / parsing supporting various protocols."
+HOMEPAGE="https://github.com/mike01/pypacker"
+SRC_URI="https://github.com/mike01/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}