summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-03-15 17:57:49 +0000
committerAli Polatel <hawking@gentoo.org>2007-03-15 17:57:49 +0000
commit76f7d5fae9947d37139eacc48175e77d2091653a (patch)
treefcb11a73e950eb7f714d61a5714f75d39a57afe7
parentdev-util/ticpp: ticpp is a fork of tinyxml and not a plain wrapper that build... (diff)
downloadsunrise-76f7d5fae9947d37139eacc48175e77d2091653a.tar.gz
sunrise-76f7d5fae9947d37139eacc48175e77d2091653a.tar.bz2
sunrise-76f7d5fae9947d37139eacc48175e77d2091653a.zip
dev-python/pycallgraph: New ebuild for bug 170806, thanks to Trevor Hardcastle
svn path=/sunrise/; revision=3248
-rw-r--r--dev-python/pycallgraph/ChangeLog8
-rw-r--r--dev-python/pycallgraph/Manifest4
-rw-r--r--dev-python/pycallgraph/files/digest-pycallgraph-0.3.03
-rw-r--r--dev-python/pycallgraph/metadata.xml5
-rw-r--r--dev-python/pycallgraph/pycallgraph-0.3.0.ebuild28
5 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pycallgraph/ChangeLog b/dev-python/pycallgraph/ChangeLog
new file mode 100644
index 000000000..c65218bb2
--- /dev/null
+++ b/dev-python/pycallgraph/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/pycallgraph
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 15 Mar 2007; Ali Polatel (hawking) <polatel@nerdshack.com>
+ +pycallgraph-0.3.0.ebuild, +metadata.xml:
+ New ebuild for bug 170806, thanks to Trevor Hardcastle
+
diff --git a/dev-python/pycallgraph/Manifest b/dev-python/pycallgraph/Manifest
new file mode 100644
index 000000000..c1b86029a
--- /dev/null
+++ b/dev-python/pycallgraph/Manifest
@@ -0,0 +1,4 @@
+DIST pycallgraph-0.3.0.tar.gz 4394 RMD160 d2c7720b6cfbdf01bc920f84b9a207161aa9dbd1 SHA1 589c93743199c275ae4b619f101350ce7e1a2227 SHA256 9942eeb5454c03f4696aea4f2c9ed65e626d3548f565caea151a1506a7a5acc9
+EBUILD pycallgraph-0.3.0.ebuild 576 RMD160 b288d750aeabeda0f7dbd08242ba7d9b338ff65b SHA1 ee628f3163f37071898dfd726b6f0f8ddfe5db3f SHA256 1d9cc0f484e394dbe6464f4410a336b7a5811148e2e561de6bbf69a8eb013b15
+MISC ChangeLog 286 RMD160 55952493359c8c1fafd0d8ef62aded4b8365e5ff SHA1 888b0748816e133e45964b3f3988b4aea4e9b3ca SHA256 edb27e0ebd76ca2eb9e9d84681b60016a17579057c8141dd4f6ace4e33f81a2a
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pycallgraph/files/digest-pycallgraph-0.3.0 b/dev-python/pycallgraph/files/digest-pycallgraph-0.3.0
new file mode 100644
index 000000000..d0c0ecb15
--- /dev/null
+++ b/dev-python/pycallgraph/files/digest-pycallgraph-0.3.0
@@ -0,0 +1,3 @@
+MD5 e851aa29c38a7609f9990e8867b322df pycallgraph-0.3.0.tar.gz 4394
+RMD160 d2c7720b6cfbdf01bc920f84b9a207161aa9dbd1 pycallgraph-0.3.0.tar.gz 4394
+SHA256 9942eeb5454c03f4696aea4f2c9ed65e626d3548f565caea151a1506a7a5acc9 pycallgraph-0.3.0.tar.gz 4394
diff --git a/dev-python/pycallgraph/metadata.xml b/dev-python/pycallgraph/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-python/pycallgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild b/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild
new file mode 100644
index 000000000..1b99847e7
--- /dev/null
+++ b/dev-python/pycallgraph/pycallgraph-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Python library that creates call graphs for Python programs."
+HOMEPAGE="http://pycallgraph.slowchop.com/"
+SRC_URI="http://${PN}.slowchop.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}