summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Francis Roy (jeanfrancis) <jeanfrancisroy@gmail.com>2009-10-20 20:34:00 +0000
committerJean-Francis Roy (jeanfrancis) <jeanfrancisroy@gmail.com>2009-10-20 20:34:00 +0000
commit77890a92f44fcaf0c6192130c50ffc15a5dd5f38 (patch)
tree2252b39bf820a0a34da27c5177796c6d2f090e9d
parentdev-util/stressapptest: dev-util/stressapptest Inital commit for bug 289320 (diff)
downloadsunrise-77890a92f44fcaf0c6192130c50ffc15a5dd5f38.tar.gz
sunrise-77890a92f44fcaf0c6192130c50ffc15a5dd5f38.tar.bz2
sunrise-77890a92f44fcaf0c6192130c50ffc15a5dd5f38.zip
dev-python/openopt: New Ebuild for bug 289363 thanks for jlec, chiiph and Tommy[D]
svn path=/sunrise/; revision=9391
-rw-r--r--dev-python/openopt/ChangeLog8
-rw-r--r--dev-python/openopt/Manifest4
-rw-r--r--dev-python/openopt/metadata.xml5
-rw-r--r--dev-python/openopt/openopt-0.25.ebuild27
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/openopt/ChangeLog b/dev-python/openopt/ChangeLog
new file mode 100644
index 000000000..b628c6b7e
--- /dev/null
+++ b/dev-python/openopt/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/openopt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 20 Oct 2009; Jean-Francis Roy (jeanfrancis) <jeanfrancisroy@gmail.com>
+ +openopt-0.25.ebuild, +metadata.xml:
+ New Ebuild for bug 289363 thanks for jlec, chiiph and Tommy[D]
+
diff --git a/dev-python/openopt/Manifest b/dev-python/openopt/Manifest
new file mode 100644
index 000000000..d663aa738
--- /dev/null
+++ b/dev-python/openopt/Manifest
@@ -0,0 +1,4 @@
+DIST OpenOpt0.25.zip 252231 RMD160 6efbaf07ddb5aa4d3003c37d80bcb4944d9f1f2e SHA1 e37b0ea28cdefa9b3962d2d6a9deef4898f3cb34 SHA256 4ff62906613f273675c71fb53fea1f850991887009b9255c2e3d56d486f8b79e
+EBUILD openopt-0.25.ebuild 562 RMD160 a47c1594ea24eb54c37a38a7ee096dcc5784aebc SHA1 532f8141556e0d6a49f7f534d3d7683c4e3f9123 SHA256 ce60f49819f068382eef1a5ef640b9e6ee28214490576108f54e4e0c9998a14a
+MISC ChangeLog 297 RMD160 58232c0f17c9593aa7ea411d03c93484b1751a4d SHA1 9c6f9a0e31b4a05303b43a7763023d79fd10b5b4 SHA256 e75719503a5b74b7668f059152667257e670663c2d1270328198b551b90cf9b5
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/openopt/metadata.xml b/dev-python/openopt/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-python/openopt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-python/openopt/openopt-0.25.ebuild b/dev-python/openopt/openopt-0.25.ebuild
new file mode 100644
index 000000000..33ef069e9
--- /dev/null
+++ b/dev-python/openopt/openopt-0.25.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_MODNAME="openopt"
+
+inherit distutils
+
+MY_PN="OpenOpt"
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="A python module for numerical optimization"
+HOMEPAGE="http://openopt.org"
+SRC_URI="ftp://ftp.linux.kiev.ua/pub/projects/${PN}/download/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/numpy"
+
+S=${WORKDIR}/${MY_PN}/