summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaime Martín (el_salmon) <jaime.martin@uc3m.es>2007-07-18 21:39:06 +0000
committerJaime Martín (el_salmon) <jaime.martin@uc3m.es>2007-07-18 21:39:06 +0000
commit8076802c994595622a8b474b10d83f1241b89772 (patch)
tree0bd0f3128f4dd3d7b5583b7c251682477ea71522
parentsys-libs/libfaketime: New Ebuild for bug 185753 thanks to Thomas Holder (diff)
downloadsunrise-8076802c994595622a8b474b10d83f1241b89772.tar.gz
sunrise-8076802c994595622a8b474b10d83f1241b89772.tar.bz2
sunrise-8076802c994595622a8b474b10d83f1241b89772.zip
swfdec-mozilla/swfdec-mozilla-0.5.0.ebuild: Version bump and a little cleaning for bug 105823
svn path=/sunrise/; revision=4279
-rw-r--r--net-www/swfdec-mozilla/ChangeLog4
-rw-r--r--net-www/swfdec-mozilla/swfdec-mozilla-0.5.0.ebuild28
2 files changed, 32 insertions, 0 deletions
diff --git a/net-www/swfdec-mozilla/ChangeLog b/net-www/swfdec-mozilla/ChangeLog
index 2ea9df89f..4d54d060e 100644
--- a/net-www/swfdec-mozilla/ChangeLog
+++ b/net-www/swfdec-mozilla/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Jul 2007; Jaime Martín (el_salmon) <jaime.martin@uc3m.es>
+ +swfdec-mozilla-0.5.0.ebuild:
+ Version bump and a little cleaning for bug 105823
+
30 Jun 2007; Jakub Moc <jakub@gentoo.org> swfdec-mozilla-0.4.5.ebuild:
Fix multilib handling, nuke redundant inherits
diff --git a/net-www/swfdec-mozilla/swfdec-mozilla-0.5.0.ebuild b/net-www/swfdec-mozilla/swfdec-mozilla-0.5.0.ebuild
new file mode 100644
index 000000000..a818eaa29
--- /dev/null
+++ b/net-www/swfdec-mozilla/swfdec-mozilla-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils nsplugins
+
+DESCRIPTION="Swfdec-mozilla is a decoder/renderer netscape style plugin for Macromedia Flash animations."
+HOMEPAGE="http://swfdec.freedesktop.org/"
+SRC_URI="http://swfdec.freedesktop.org/download/${PN}/${PV:0:3}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/swfdec-0.5.0
+ || ( www-client/mozilla-firefox www-client/seamonkey )"
+RDEPEND=""
+
+src_install() {
+ exeinto /usr/lib/nsbrowser/plugins
+ doexe src/.libs/libswfdecmozilla.so || die "libswfdecmozilla.so failed"
+ insinto /usr/lib/nsbrowser/plugins
+ doins src/libswfdecmozilla.la
+}
+
+pkg_postinst() {
+ einfo "Remember to report bugs to: https://bugzilla.freedesktop.org"
+}