summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-13 22:38:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-13 22:38:33 +0000
commita16f06ddde388f6cc73a46e128a9ae04fe5db947 (patch)
treef0b19a9438fe883e8db4596eb6d433186f55cafa
parentMasking net-analyzer/honeytrap (diff)
downloadsunrise-a16f06ddde388f6cc73a46e128a9ae04fe5db947.tar.gz
sunrise-a16f06ddde388f6cc73a46e128a9ae04fe5db947.tar.bz2
sunrise-a16f06ddde388f6cc73a46e128a9ae04fe5db947.zip
app-text/pdfedit: Eapi2fy it. Apply patch to fix boost compilation problems ( bug 277723 )
svn path=/sunrise/; revision=8824
-rw-r--r--app-text/pdfedit/ChangeLog6
-rw-r--r--app-text/pdfedit/Manifest5
-rw-r--r--app-text/pdfedit/files/boost_compile.patch31
-rw-r--r--app-text/pdfedit/pdfedit-0.4.1.ebuild11
4 files changed, 47 insertions, 6 deletions
diff --git a/app-text/pdfedit/ChangeLog b/app-text/pdfedit/ChangeLog
index f05d20585..a11195e6f 100644
--- a/app-text/pdfedit/ChangeLog
+++ b/app-text/pdfedit/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-text/pdfedit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Jul 2009; Markos Chandras <hwoarang@gentoo.org> pdfedit-0.4.1.ebuild,
+ +files/boost_compile.patch:
+ Eapi2fy it. Apply patch to fix boost compilation problems ( bug 277723 )
+
17 Jun 2008; Thomas Anderson (gentoofan23) <gentoofan23@gmail.com>
pdfedit-0.4.1.ebuild:
Fix Access violations to /usr/qt/3/etc/settings, thanks to klink in
diff --git a/app-text/pdfedit/Manifest b/app-text/pdfedit/Manifest
index 47d9d4f95..77f816b71 100644
--- a/app-text/pdfedit/Manifest
+++ b/app-text/pdfedit/Manifest
@@ -1,4 +1,5 @@
+AUX boost_compile.patch 1319 RMD160 84628958697ac4e9afae5d953ed1d39db3603eec SHA1 022712dcbd0ee364b60933275ea837c73bd5d9bb SHA256 68165a9258bd4585817db7d1fa804300964d79f77163979847d0b322635245d5
DIST pdfedit-0.4.1.tar.gz 3361429 RMD160 e8ce8a69d740440f533b67e393ab2fab58a2b283 SHA1 4d9e5df215ed6ce89396d8f8406bba92f15a70cc SHA256 93304e374f40c2dba1f0087b840cd0a30a16907ac8908a21d443c6e94e34cfc5
-EBUILD pdfedit-0.4.1.ebuild 673 RMD160 7cc953c89ef9d3b1c58ddbb5556f4c918b24ad65 SHA1 598cdd208f197c3bf716d3797abe3e048c1679b9 SHA256 4f56df06668bbbbc72b0946a69922d66db267898d3f60994d630f43e6b967417
-MISC ChangeLog 2027 RMD160 22e24a704e3396386180087becaf5fbc515acce6 SHA1 d59a034b3f63238008ed40af79badc343e17ffd8 SHA256 0f59da8ff9c9a65896fd1a7af7073dae8fdf48f6cc0f5ad9cb8021d821a69c6b
+EBUILD pdfedit-0.4.1.ebuild 718 RMD160 be100f942050715bfb261641bb60871d229413e6 SHA1 d98fc77befa51c15d2db26fedbe8dd0f477b3c02 SHA256 5ca82cbf7463de8eb6f09ee4f50d1d4eda917fdc244a8a0f2e6199fff86e4fd6
+MISC ChangeLog 2208 RMD160 7e33a97ab1900182c22a19592d268a896584c5c4 SHA1 0f7dac870744c22efe12904df8755e603f3b0518 SHA256 90d065815c5b64addb0420b573f555abb715c89ccd0a26731e14a9ec60eb5b30
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-text/pdfedit/files/boost_compile.patch b/app-text/pdfedit/files/boost_compile.patch
new file mode 100644
index 000000000..0221b808e
--- /dev/null
+++ b/app-text/pdfedit/files/boost_compile.patch
@@ -0,0 +1,31 @@
+Index: pdfedit-0.4.1/src/kernel/cpdf.cc
+===================================================================
+--- pdfedit-0.4.1.orig/src/kernel/cpdf.cc 2008-11-19 23:15:28.000000000 +0100
++++ pdfedit-0.4.1/src/kernel/cpdf.cc 2008-11-19 23:16:59.000000000 +0100
+@@ -2347,7 +2347,7 @@ using namespace std;
+ instance->file = file;
+ kernelPrintDbg(debug::DBG_INFO, "Instance created successfully openMode=" << openMode);
+ return instance;
+- }catch(exception &e)
++ }catch(std::exception &e)
+ {
+ kernelPrintDbg(DBG_CRIT, "Pdf instance creation failed. cause="<<e.what());
+ string what=string("CPdf open failed. reason=")+e.what();
+@@ -2631,7 +2631,7 @@ using namespace utils;
+ try
+ {
+ minPos = getNodePosition(*this, newValue, &nodeCountCache);
+- }catch(exception &e)
++ }catch(std::exception &e)
+ {
+ // position can't be determined
+ // no special handling is needed, minPos keeps its value
+@@ -2690,7 +2690,7 @@ using namespace utils;
+ kernelPrintDbg(DBG_WARN, "page with original position="<<i->first<<" is ambiguous. Invalidating.");
+ // page position is ambiguous and so it has to be invalidate
+ i->second->invalidate();
+- }catch(exception & e)
++ }catch(std::exception & e)
+ {
+ kernelPrintDbg(DBG_CRIT, "Unexpected error. cause="<<e.what());
+ assert(!"Possibly bug.");
diff --git a/app-text/pdfedit/pdfedit-0.4.1.ebuild b/app-text/pdfedit/pdfedit-0.4.1.ebuild
index 1bc3fb8d9..bc6d1dfab 100644
--- a/app-text/pdfedit/pdfedit-0.4.1.ebuild
+++ b/app-text/pdfedit/pdfedit-0.4.1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit qt3
DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
@@ -19,9 +21,12 @@ DEPEND="${RDEPEND}
dev-libs/boost
doc? ( app-doc/doxygen )"
-src_compile(){
+src_prepare() {
+ epatch "${FILESDIR}/boost_compile.patch"
+}
+
+src_configure() {
econf $(use_enable doc doxygen-doc) $(use_enable doc advanced-doc)
- emake || die "emake failed"
}
src_install() {