summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Carr (mca) <karman05@gmail.com>2010-12-18 00:58:54 +0000
committerMatt Carr (mca) <karman05@gmail.com>2010-12-18 00:58:54 +0000
commitbce4785c2377c575b6456ac6410a67aca685c74a (patch)
treea930780aab792765bf946d4bea67d5bce418cd5e
parentdev-util/jsmin: Fix up jsmin ebuild to comply with tommy[d]'s standards of ac... (diff)
downloadsunrise-bce4785c2377c575b6456ac6410a67aca685c74a.tar.gz
sunrise-bce4785c2377c575b6456ac6410a67aca685c74a.tar.bz2
sunrise-bce4785c2377c575b6456ac6410a67aca685c74a.zip
media-sound/pithos: Updated ebuild for pithos, better distutils compliance, thanks to mgorny and Arfrever
svn path=/sunrise/; revision=11619
-rw-r--r--media-sound/pithos/ChangeLog4
-rw-r--r--media-sound/pithos/Manifest4
-rw-r--r--media-sound/pithos/pithos-9999.ebuild13
3 files changed, 11 insertions, 10 deletions
diff --git a/media-sound/pithos/ChangeLog b/media-sound/pithos/ChangeLog
index 935d5eb1a..12224c3cb 100644
--- a/media-sound/pithos/ChangeLog
+++ b/media-sound/pithos/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 18 Dec 2010; Matt Carr (mca) <karman05@gmail.com> ,pithos-9999.ebuild:
+ Updated ebuild for pithos, better distutils compliance, thanks to mgorny and
+ Arfrever
+
06 Dec 2010; Matt Carr (mca) <karman05@gmail.com> +pithos-9999.ebuild,
+metadata.xml:
New Ebuild for bug 345815 thanks to marienz, floppym, Hawk777, chithead, and
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index 341f0c82e..827688259 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1,3 +1,3 @@
-EBUILD pithos-9999.ebuild 1134 RMD160 d7f66eaf181b1536e6ae1f13c1297200235b41bc SHA1 45b308b81894c6f2d2618bb72a8e46444d90b460 SHA256 8a142126566b5b2d103d8c476e66c13bc29d73f5553b307ab8931c1faabde4b8
-MISC ChangeLog 300 RMD160 cf44d78442ecffd5ab39f5337eba2af0c1f37159 SHA1 0c67663b602744c43c58a3245f8a58948be38fa4 SHA256 abcff19c5eba2bc718d02b8a2f8ad0ce06e5767a145ab9c4c3ad489e827ceceb
+EBUILD pithos-9999.ebuild 1078 RMD160 d9863a4aac293b3d56b9f1659e9ab63f3d8a0186 SHA1 059f2af997a7ac0164dc98666c57c7c393fd1f0f SHA256 2890c2f2bb2a8b69b66e8dc11c0bda2b7c4d10956d670575d0e69653bd5381da
+MISC ChangeLog 464 RMD160 5b80146b51ea0eb4b2c3bf7859d41b93d1287808 SHA1 ea118dca750ac1c0907fe172427cf039a4174ab7 SHA256 ef4ecec4c3084776c0554fb69c98bbe873f9ee5a29effb87094076f3cc5a0c41
MISC metadata.xml 345 RMD160 edbbe3bec71a1370f73e5542e5473eb57708dea2 SHA1 636ea62d307ca41d9c9dec762e6c13a726dcc48c SHA256 27eeccc602853e301ea217d45c4ea57ce2d74fc86edf77c755bfd138304dbc13
diff --git a/media-sound/pithos/pithos-9999.ebuild b/media-sound/pithos/pithos-9999.ebuild
index 4fa2aba47..d058636bd 100644
--- a/media-sound/pithos/pithos-9999.ebuild
+++ b/media-sound/pithos/pithos-9999.ebuild
@@ -7,9 +7,9 @@ PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
inherit bzr distutils
+EBZR_REPO_URI="lp:${PN}"
DESCRIPTION="A Pandora Radio (pandora.com) player for the GNOME Desktop"
HOMEPAGE="http://kevinmehall.net/p/pithos/"
-EBZR_REPO_URI="lp:${PN}"
LICENSE="GPL-3"
SLOT="0"
@@ -32,19 +32,16 @@ RDEPEND="dev-python/pyxdg
!gnome? ( dev-libs/keybinder )"
RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
src_prepare() {
+ distutils_src_prepare
+
# bug #216009
# avoid writing to /root/.gstreamer-0.10/registry.xml
export GST_REGISTRY="${T}"/registry.xml
- python_copy_sources
}
src_install() {
- installation() {
- "$(PYTHON)" \
- setup.py \
- install --root="${D}" --no-compile --prefix="${EPREFIX}"/usr
- }
- python_execute_function -s installation
+ distutils_src_install --prefix="${EPREFIX}/usr"
}