summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2008-09-02 18:24:13 +0000
committerTom Hendrikx (whyscream) <tom@whyscream.net>2008-09-02 18:24:13 +0000
commitc1fb093e3927ba7adaa74f9d5625c425b9259e8f (patch)
treecc5245ee1f56c51a4cc784e9e590f93057fbfd01
parentNew USE flags for new ebuild dev-libs/ldns (diff)
downloadsunrise-c1fb093e3927ba7adaa74f9d5625c425b9259e8f.tar.gz
sunrise-c1fb093e3927ba7adaa74f9d5625c425b9259e8f.tar.bz2
sunrise-c1fb093e3927ba7adaa74f9d5625c425b9259e8f.zip
net-libs/ldns: New ebuild for net-libs/ldns, see bug #192728
svn path=/sunrise/; revision=6954
-rw-r--r--net-libs/ldns/ChangeLog8
-rw-r--r--net-libs/ldns/Manifest4
-rw-r--r--net-libs/ldns/ldns-1.3.0.ebuild67
-rw-r--r--net-libs/ldns/metadata.xml9
4 files changed, 88 insertions, 0 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
new file mode 100644
index 000000000..8d46ce5e1
--- /dev/null
+++ b/net-libs/ldns/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-libs/ldns
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Sep 2008; Tom Hendrikx (whyscream) <tom@whyscream.net>
+ +ldns-1.3.0.ebuild, +metadata.xml:
+ New ebuild for net-libs/ldns, see bug #192728
+
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
new file mode 100644
index 000000000..36f6e8559
--- /dev/null
+++ b/net-libs/ldns/Manifest
@@ -0,0 +1,4 @@
+DIST ldns-1.3.0.tar.gz 786124 RMD160 5d603018f2c772108c3696c1e90398aea20a05bf SHA1 9b05ea3ae23f973345de89936c59ad79f77aeccf SHA256 85185cbcbdffee7cd38184fac3c3eb0ab4a1631f5d0f5097b8789f26a942b9e2
+EBUILD ldns-1.3.0.ebuild 1513 RMD160 7687236f4d574bed6b7b409a0756cb17f04db986 SHA1 5e4d3c5208dcb12ac08e14f342adc2c141ba48b4 SHA256 4fc1f13200c3b7747af3307e54c5690a7f998e2ada00e7c15e0f492637f7bcad
+MISC ChangeLog 260 RMD160 fa8a7c6ee9241118149dbd84a432a2cde1a2357c SHA1 e2451790843b48f7efcfc154020d94ed1a9c94bf SHA256 3952f6f3a584bd051bbd2323b7093e55030e7a2116ffc3705601f43880e3971d
+MISC metadata.xml 328 RMD160 bbef185842e1039caba6fd9116df355ce28fb18a SHA1 fc3578a06f493d02006121bd38fc44654dec560d SHA256 6ac10326cfe1f097fec33aaafc265c003d2e2488e1382a0cff76764f89ce5b6a
diff --git a/net-libs/ldns/ldns-1.3.0.ebuild b/net-libs/ldns/ldns-1.3.0.ebuild
new file mode 100644
index 000000000..bb6a3fbc4
--- /dev/null
+++ b/net-libs/ldns/ldns-1.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="drill examples utils"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ utils? ( net-libs/libpcap )"
+
+src_compile() {
+ einfo "Buildig libldns"
+ econf
+ emake || die "libldns compilation failed"
+
+ if use drill; then
+ einfo "Building drill"
+ cd drill
+ econf
+ emake || die "drill compilation failed"
+ cd ..
+ fi
+
+ if use utils; then
+ einfo "Building example utilities"
+ cd examples
+ econf
+ emake || die "example utilities compilation failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "libldns installation failed"
+
+ if use drill; then
+ cd drill
+ emake DESTDIR="${D}" install || die "drill installation failed"
+ cd ..
+ fi
+
+ if use utils; then
+ cd examples
+ emake DESTDIR="${D}" install || die "example utilities installation failed"
+ cd ..
+ fi
+
+ dodoc Changelog README || die "Adding documentation failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "Adding examples to documentation failed"
+ fi
+}
+
+pkg_postinst() {
+ if use utils; then
+ ewarn "You enabled the "utils" USE flag, which installs the example utilities."
+ ewarn "Most of them are quite useful, but not all of them are production-ready."
+ fi
+}
diff --git a/net-libs/ldns/metadata.xml b/net-libs/ldns/metadata.xml
new file mode 100644
index 000000000..295da863d
--- /dev/null
+++ b/net-libs/ldns/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <use>
+ <flag name='drill'>Enable installation of the drill utility</flag>
+ <flag name='utils'>Enable installation of the example utilities</flag>
+ </use>
+</pkgmetadata>