summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuan Aguado (juantxorena) <juantxorena@gmail.com>2007-05-26 17:44:26 +0000
committerJuan Aguado (juantxorena) <juantxorena@gmail.com>2007-05-26 17:44:26 +0000
commitd309175ece61353673624b965fc76d5d29d9de2a (patch)
tree787ce6acbd49ed7128d4034ff3c1155ba19335f2
parentNuke redundant ${S} usage (diff)
downloadsunrise-d309175ece61353673624b965fc76d5d29d9de2a.tar.gz
sunrise-d309175ece61353673624b965fc76d5d29d9de2a.tar.bz2
sunrise-d309175ece61353673624b965fc76d5d29d9de2a.zip
media-video/subtitleeditor: Version bump
svn path=/sunrise/; revision=3755
-rw-r--r--media-video/subtitleeditor/ChangeLog4
-rw-r--r--media-video/subtitleeditor/Manifest4
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.13.6.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index c820ff65b..2846894d7 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 May 2007; Juan Aguado (juantxorena) <juantxorena666@gmail.com>
+ +subtitleeditor-0.13.6.ebuild:
+ Version bump
+
15 Apr 2007; Juan Aguado (juantxorena) <juantxorena666@gmail.com>
-subtitleeditor-0.13.1.ebuild, +subtitleeditor-0.13.4.ebuild:
Version bump
diff --git a/media-video/subtitleeditor/Manifest b/media-video/subtitleeditor/Manifest
index 71717800c..3d70078e3 100644
--- a/media-video/subtitleeditor/Manifest
+++ b/media-video/subtitleeditor/Manifest
@@ -1,4 +1,6 @@
DIST subtitleeditor-0.13.4.tar.gz 578269 RMD160 636e5f4d6d9a30e44425ab9c464175e58594d0c2 SHA1 99a9f5020bc98919e29e237a4a2fc73496b65c34 SHA256 f27342ed890329342d84ef24417007229d6bbca631c0e4b41c7e950fd8ffc1a0
+DIST subtitleeditor-0.13.6.tar.gz 579871 RMD160 28c8760a85f9e6106dcb0a6c7adc550858b8cf2a SHA1 ea932a3530bd70d379ea48d2ed316f0f55059a01 SHA256 5c63baa89443dc96e2e86e8cd6719cc0df0eed9ea713c0f41d418d9ee318b6aa
EBUILD subtitleeditor-0.13.4.ebuild 1371 RMD160 40d3e1b7d69e08cc571b21b65d1af9d3e147157c SHA1 65cf8266460d77e3316a4bf7eff75997bb61dbe3 SHA256 292e3c5d37e63b7e8841c84d35d0e2fcc40962336425d00d7412cbd01abc03f0
-MISC ChangeLog 1235 RMD160 dc6411947b7a76dd117d1a4522ec694bed9fd410 SHA1 8ff9fd69f7404a8a02fd2bf161c3249d97a4d333 SHA256 a24a0d41efd8779027f2113eb327093b52c983f6f5a7348047d921ba5a012030
+EBUILD subtitleeditor-0.13.6.ebuild 1371 RMD160 40d3e1b7d69e08cc571b21b65d1af9d3e147157c SHA1 65cf8266460d77e3316a4bf7eff75997bb61dbe3 SHA256 292e3c5d37e63b7e8841c84d35d0e2fcc40962336425d00d7412cbd01abc03f0
+MISC ChangeLog 1352 RMD160 560e467a73d3839d1b884395e24efb0135074dc9 SHA1 808eac4880be79698940d50de3111aeb891abcdd SHA256 15f233f274fc7735c2c3eeb8ce31a28d459b9a16f8f61683134761a62bee02e0
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-video/subtitleeditor/subtitleeditor-0.13.6.ebuild b/media-video/subtitleeditor/subtitleeditor-0.13.6.ebuild
new file mode 100644
index 000000000..f0f45e21c
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.13.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A GTK+ subtitle editing tool"
+HOMEPAGE="http://kitone.free.fr/subtitleeditor/"
+SRC_URI="http://kitone.free.fr/${PN}/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo debug spell"
+
+# pcre needs to support utf8; current version in portage forces it, fortunately
+DEPEND=">=dev-cpp/gtkmm-2.6
+ >=dev-cpp/libglademm-2.4
+ dev-libs/libpcre
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=x11-libs/gtk+-2.6
+ cairo? ( x11-libs/cairo )
+ spell? ( >=app-text/enchant-1.1.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+ addpredict "${ROOT}root/.gconf"
+ addpredict "${ROOT}root/.gconfd"
+ econf \
+ $(use_enable cairo) \
+ $(use_enable debug) \
+ $(use_enable spell enchant-support) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ # Bug filed upstream -- (which bug is it and what does it fix?)
+ sed -i -e "s:${PN}-icon:/usr/share/${PN}/${PN}:" "share/${PN}.desktop"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README TODO
+}
+
+pkg_postinst() {
+ use cairo && ewarn "Cairo support is not finished -- use at your own risk!"
+}