summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 12:02:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 12:02:28 +0000
commite0d99d4f4c00a3998627880bff6760274c675cef (patch)
tree6b63ccfc58b740a93f4d186c2b6f6bc17b5079ae
parentdev-python/pip: Corrected for distutils EAPI <=2 deprecation warning (diff)
downloadsunrise-e0d99d4f4c00a3998627880bff6760274c675cef.tar.gz
sunrise-e0d99d4f4c00a3998627880bff6760274c675cef.tar.bz2
sunrise-e0d99d4f4c00a3998627880bff6760274c675cef.zip
app-admin/log4tailer: Corrected for distutils EAPI <=2 deprecation warning, Version Bump
svn path=/sunrise/; revision=11929
-rw-r--r--app-admin/log4tailer/ChangeLog6
-rw-r--r--app-admin/log4tailer/Manifest6
-rw-r--r--app-admin/log4tailer/log4tailer-3.0.ebuild (renamed from app-admin/log4tailer/log4tailer-2.0.ebuild)15
3 files changed, 19 insertions, 8 deletions
diff --git a/app-admin/log4tailer/ChangeLog b/app-admin/log4tailer/ChangeLog
index b7d835e08..aac4b37bd 100644
--- a/app-admin/log4tailer/ChangeLog
+++ b/app-admin/log4tailer/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-admin/log4tailer
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2011; Justin Lecher <jlec@gentoo.org> -log4tailer-2.0.ebuild,
+ +log4tailer-3.0.ebuild:
+ Corrected for distutils EAPI <=2 deprecation warning, Version Bump
+
22 Aug 2010; Markos Chandras <hwoarang@gentoo.org> log4tailer-2.0.ebuild:
Rename dev-python/pymox -> dev-python/mox
diff --git a/app-admin/log4tailer/Manifest b/app-admin/log4tailer/Manifest
index 2aec3e330..74cc29f1c 100644
--- a/app-admin/log4tailer/Manifest
+++ b/app-admin/log4tailer/Manifest
@@ -1,4 +1,4 @@
-DIST log4tailer-2.0.tar.gz 36100 RMD160 17138903fdaa2e581c38277a7a6c9ab1ec7e3ba6 SHA1 bf005eae92b4bffbe1a37beb5f43a080c4904ec8 SHA256 aabb216476b9cc00c08aab36b7ca8004e4b7d4291bb5d4ef7b6789317ebd2943
-EBUILD log4tailer-2.0.ebuild 705 RMD160 70582ab576bac72b19a7199ba3269a792612695e SHA1 d95b8ddf0a411ae2cb29149f4a52669a3fd01db1 SHA256 2cdfb709aa46a925df6ca1b5841aabd14be2435aa4358e15c3050a04a7715061
-MISC ChangeLog 399 RMD160 777f6d51e88756990dce98b85385643edaff2065 SHA1 84a4bdaccdbd0c7d6a95b6c8b973ee35ee918782 SHA256 3e8d2ce913d1ce75182debd55bc84655f04c7cba2bfbdb3a64877bf09b622e4b
+DIST log4tailer-3.0.tar.gz 57848 RMD160 08cdcc51290c2f614593ed316ade6641ed357d17 SHA1 2c68c947cdbee76148e9ab91ec7f607716f5cad4 SHA256 dc393aec1f08bccd294239c1a202110381275c92c3c00a8e61373e6e1ce8809e
+EBUILD log4tailer-3.0.ebuild 757 RMD160 a406921ab28200d1603a5fb91674bfd29dd0b151 SHA1 1221e5a0ef53922939bc40ed8d4a58110d21f4ba SHA256 1a4fe0cb18f21e3e7e71b4cd22485358e4941f385ecbe27e9cc167333dfd4738
+MISC ChangeLog 566 RMD160 418c2ced24c12433ce62bd61881d16f10cc8d0d7 SHA1 a75535c7d00d3dfcfa4aa1bea6c074a9bd217a6c SHA256 03d681b169c8e0db891ac45f13326d258b5b47e7d85618e662447c21314c0c15
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/app-admin/log4tailer/log4tailer-2.0.ebuild b/app-admin/log4tailer/log4tailer-3.0.ebuild
index b3f001f25..8f68557bc 100644
--- a/app-admin/log4tailer/log4tailer-2.0.ebuild
+++ b/app-admin/log4tailer/log4tailer-3.0.ebuild
@@ -1,12 +1,16 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
-DESCRIPTION="Log4tailer is a python tailer with advanced features"
+DESCRIPTION="Advanced log tailer written in python"
HOMEPAGE="http://code.google.com/p/log4tailer/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
@@ -18,10 +22,13 @@ IUSE="test"
DEPEND="dev-python/setuptools
test? ( dev-python/mox
dev-python/paramiko )"
-RDEPEND="virtual/python"
+RDEPEND=""
src_test() {
- PYTHONPATH=. "${python}" setup.py test || die "tests failed"
+ testing() {
+ PYTHONPATH=. $(PYTHON) setup.py test
+ }
+ python_execute_function testing
}
src_install() {