summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-04-23 02:41:51 +0200
committerhasufell <julian.ospald@googlemail.com>2012-04-23 02:41:51 +0200
commite3c0120ee61110faab47ca30d9f2c5ca72e9c6c4 (patch)
treef2ae16a27bd7fcd58a97650c48481838b697b0aa
parentdev-games/gigi: New Ebuild for bug 349367 thanks to all (diff)
downloadsunrise-e3c0120ee61110faab47ca30d9f2c5ca72e9c6c4.tar.gz
sunrise-e3c0120ee61110faab47ca30d9f2c5ca72e9c6c4.tar.bz2
sunrise-e3c0120ee61110faab47ca30d9f2c5ca72e9c6c4.zip
games-strategy/freeorion: New Ebuild for bug 402019 thanks to all
-rw-r--r--games-strategy/freeorion/ChangeLog10
-rw-r--r--games-strategy/freeorion/Manifest3
-rw-r--r--games-strategy/freeorion/freeorion-0.3.17_p4823.ebuild104
-rw-r--r--games-strategy/freeorion/metadata.xml10
4 files changed, 127 insertions, 0 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
new file mode 100644
index 000000000..e50351614
--- /dev/null
+++ b/games-strategy/freeorion/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-strategy/freeorion
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*freeorion-0.3.17_p4823 (23 Apr 2012)
+
+ 23 Apr 2012; hasufell <julian.ospald@googlemail.com>
+ +freeorion-0.3.17_p4823.ebuild, +metadata.xml:
+ New Ebuild for bug 402019 thanks to all
+
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
new file mode 100644
index 000000000..4a7b0a7ac
--- /dev/null
+++ b/games-strategy/freeorion/Manifest
@@ -0,0 +1,3 @@
+EBUILD freeorion-0.3.17_p4823.ebuild 2471 RMD160 e94f6f02c4fbe9560b249ac13d95a9c234695ffb SHA1 4ac103b0b484d562d27859c3d2e1e6e56fe16ac3 SHA256 994ec221697e1fc5d7b66b17ee6ba613aebf5cb781cb1cf4d0bc19ca39795899
+MISC ChangeLog 311 RMD160 b99c6c1608a0c3811be53894b8f7cb21a96e43d7 SHA1 3222ab8bbaf5fdbb8cce039199b49b1a2a166d14 SHA256 ebd6fbecd01f1c649d1990b5b08fc2612eef81d32118a4e46be04eb29f4ebbfe
+MISC metadata.xml 292 RMD160 cfccc097a16bb7e1dc694fba1f11ca50c74c8acc SHA1 ad07aef2a2b6b2370f37c9570d1e082ea2067322 SHA256 8cec5948c2ddd4e5d1db70813a9aa693d7d7ac5558631855e28c456a7a05994d
diff --git a/games-strategy/freeorion/freeorion-0.3.17_p4823.ebuild b/games-strategy/freeorion/freeorion-0.3.17_p4823.ebuild
new file mode 100644
index 000000000..73da7e19a
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.3.17_p4823.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python subversion games
+
+DESCRIPTION="A free and open source clone of Master Of Orion"
+HOMEPAGE="http://www.freeorion.org"
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/trunk"
+ESVN_PROJECT="${PN}"
+ESVN_REVISION="${PV#*_p}"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="" # dependency gigi unkeyworded and potentially broken
+IUSE="cg"
+
+RDEPEND="
+ dev-games/gigi[ogre,ois]
+ dev-games/ogre[cg?,opengl]
+ >=dev-libs/boost-1.47
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/libsdl[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+CMAKE_USE_DIR="${S}"/FreeOrion
+CMAKE_VERBOSE="1"
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ # set OGRE plugin-dir
+ sed \
+ -e "s:PluginFolder=.:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
+ -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+
+ # set revision number
+ sed \
+ -e "/svn_revision_number/s:???:${ESVN_REVISION}:" \
+ -i "${CMAKE_USE_DIR}"/CMakeLists.txt || die
+
+ if use cg ; then
+ # add cg ogre plugin to config
+ echo "Plugin=Plugin_CgProgramManager" \
+ >> "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRELEASE_COMPILE_FLAGS=""
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # data files
+ rm "${CMAKE_USE_DIR}"/default/COPYING || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${CMAKE_USE_DIR}"/default || die
+
+ # bin
+ dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die
+ newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} \
+ "${GAMES_BINDIR}/${PN}.bin --resource-dir ./default" \
+ "${GAMES_DATADIR}/${PN}"
+
+ # config
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins "${CMAKE_USE_DIR}"/{OISInput,ogre_plugins}.cfg || die
+ # game uses relative paths
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/ogre_plugins.cfg \
+ "${GAMES_DATADIR}"/${PN}/ogre_plugins.cfg || die
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/OISInput.cfg \
+ "${GAMES_DATADIR}"/${PN}/OISInput.cfg || die
+
+ # other
+ dodoc "${CMAKE_USE_DIR}"/changelog.txt || die
+ newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \
+ ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}
diff --git a/games-strategy/freeorion/metadata.xml b/games-strategy/freeorion/metadata.xml
new file mode 100644
index 000000000..a57b645fe
--- /dev/null
+++ b/games-strategy/freeorion/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="cg">Add support for NVIDIA toolkit plugin</flag>
+ </use>
+</pkgmetadata>