summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2008-07-24 22:31:52 +0000
committerMounir Lamouri <volkmar@gentoo.org>2008-07-24 22:31:52 +0000
commitebf6ef4b7ad8a86624781cdd6c45e18654df8c92 (patch)
treea55781970832857b7fa3d3cf7e513a8cd31040cc
parentmedia-tv/em28xx-new: new snapshot (diff)
downloadsunrise-ebf6ef4b7ad8a86624781cdd6c45e18654df8c92.tar.gz
sunrise-ebf6ef4b7ad8a86624781cdd6c45e18654df8c92.tar.bz2
sunrise-ebf6ef4b7ad8a86624781cdd6c45e18654df8c92.zip
dev-cpp/plotmm: Updated ebuild with libsigc++-2.2* patch
svn path=/sunrise/; revision=6562
-rw-r--r--dev-cpp/plotmm/ChangeLog4
-rw-r--r--dev-cpp/plotmm/Manifest5
-rw-r--r--dev-cpp/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch100
-rw-r--r--dev-cpp/plotmm/plotmm-0.1.2.ebuild12
4 files changed, 118 insertions, 3 deletions
diff --git a/dev-cpp/plotmm/ChangeLog b/dev-cpp/plotmm/ChangeLog
index efc29e1fc..7c240a7db 100644
--- a/dev-cpp/plotmm/ChangeLog
+++ b/dev-cpp/plotmm/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 24 Jul 2008; Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
+ plotmm-0.1.2.ebuild, +files/plotmm-0.1.2-libsigc++-2.2.patch:
+ Updated ebuild with libsigc++-2.2* patch
+
11 Jun 2008; Thomas Anderson (gentoofan23) <gentoofan23@gmail.com>
plotmm-0.1.2.ebuild:
dohtml should die if it fails
diff --git a/dev-cpp/plotmm/Manifest b/dev-cpp/plotmm/Manifest
index b50886693..71c69a21e 100644
--- a/dev-cpp/plotmm/Manifest
+++ b/dev-cpp/plotmm/Manifest
@@ -1,4 +1,5 @@
+AUX plotmm-0.1.2-libsigc++-2.2.patch 4037 RMD160 21266c4274d42e3da0957f07ae3dfb566fc9f4fd SHA1 d54faf2882060a317b0c2dc6c6395050204f3951 SHA256 6c535a0665d561841dc1fa9fce29eb18735850bea3d7af8b19e1d20050237cc6
DIST plotmm-0.1.2.tar.gz 473175 RMD160 1a42a6681f540911c58a23290e1f7f9877bc49c1 SHA1 64da0930b7c8994d59769597917cca05df989258 SHA256 896bb729eb9cad5f3188d72304789dd7a86fdae66020ac0632fe3bc66abe9653
-EBUILD plotmm-0.1.2.ebuild 607 RMD160 d12ab3abbb5a23da60321b45ebcc25bb84b522de SHA1 b3f0eea31210bc91205bb13ee672ebe9cf85c281 SHA256 c569d48fb530af2caf0bd4ab9676ba5127fdbd1335ee71f8b1b85a53e5907ef8
-MISC ChangeLog 496 RMD160 44da9410bbfad2186780a9c10358820870e6e079 SHA1 489565c2c31893f8a8a0805cda337ccb852a05e8 SHA256 29fa6a90abb97b6479d8a6909e6425c97a05bc9675952c6da2b9e30ae77dc9ea
+EBUILD plotmm-0.1.2.ebuild 714 RMD160 a138fca2f89b04c20a8be431470e3cf0df39703e SHA1 fdd8570e218c96764c6ecbc155c8955e1715256e SHA256 04cb29edf7a08898639df557fb1bd8ce89c31ef4aab485a56238973b6c0729cc
+MISC ChangeLog 671 RMD160 c4f560339d15a1ad943d1bb288c2d3bcd8ed66d5 SHA1 aca39fad0302357e3bec49adad08e8447b1d019a SHA256 d0172c170c53959bd3199bcea7ca287fa42ecb0b2e050e4539cc9bf90f1a15f4
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-cpp/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch b/dev-cpp/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
new file mode 100644
index 000000000..a9aa53190
--- /dev/null
+++ b/dev-cpp/plotmm/files/plotmm-0.1.2-libsigc++-2.2.patch
@@ -0,0 +1,100 @@
+diff -ur plotmm-0.1.2-old/plotmm/compat.h plotmm-0.1.2/plotmm/compat.h
+--- plotmm-0.1.2-old/plotmm/compat.h 2005-11-09 17:36:02.000000000 +0100
++++ plotmm-0.1.2/plotmm/compat.h 2008-07-25 00:13:55.000000000 +0200
+@@ -58,7 +58,7 @@
+ #else
+
+ namespace PlotMM {
+- typedef SigC::ObjectBase ObjectBase;
++ typedef sigc::ObjectBase ObjectBase;
+ }
+
+ #endif
+diff -ur plotmm-0.1.2-old/plotmm/curve.h plotmm-0.1.2/plotmm/curve.h
+--- plotmm-0.1.2-old/plotmm/curve.h 2005-11-09 17:47:21.000000000 +0100
++++ plotmm-0.1.2/plotmm/curve.h 2008-07-25 00:24:02.000000000 +0200
+@@ -140,7 +140,7 @@
+ int from = 0, int to = -1);
+
+ //! Signals that this curve has changed in some way or the other
+- SigC::Signal0<void> signal_curve_changed;
++ sigc::signal0<void> signal_curve_changed;
+
+ protected:
+ virtual void init(const Glib::ustring &title);
+diff -ur plotmm-0.1.2-old/plotmm/plot.cc plotmm-0.1.2/plotmm/plot.cc
+--- plotmm-0.1.2-old/plotmm/plot.cc 2005-11-09 17:59:48.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.cc 2008-07-25 00:24:30.000000000 +0200
+@@ -322,7 +322,7 @@
+ connect(sigc::mem_fun(*this,&Plot::on_canvas_expose_event));
+ #else
+ canvas_.signal_expose_event().
+- connect(SigC::slot(*this,&Plot::on_canvas_expose_event));
++ connect(sigc::slot(*this,&Plot::on_canvas_expose_event));
+ #endif
+
+ show_all();
+@@ -406,19 +406,19 @@
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_press()
+ {
+ return canvas_.signal_plot_mouse_press;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
++sigc::signal3<void,int,int,GdkEventButton*> Plot::signal_plot_mouse_release()
+ {
+ return canvas_.signal_plot_mouse_release;
+ }
+
+ //! Return the signal owned by plot canvas
+-SigC::Signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
++sigc::signal3<void,int,int,GdkEventMotion*> Plot::signal_plot_mouse_move()
+ {
+ return canvas_.signal_plot_mouse_move;
+ }
+diff -ur plotmm-0.1.2-old/plotmm/plot.h plotmm-0.1.2/plotmm/plot.h
+--- plotmm-0.1.2-old/plotmm/plot.h 2004-03-09 10:51:55.000000000 +0100
++++ plotmm-0.1.2/plotmm/plot.h 2008-07-25 00:25:17.000000000 +0200
+@@ -79,9 +79,9 @@
+ virtual void clear();
+ virtual void end_replot();
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press;
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release;
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move;
+
+ protected:
+ virtual bool on_expose_event(GdkEventExpose* event);
+@@ -141,9 +141,9 @@
+ Scale *scale(PlotAxisID id) { return tickMark_[id]; }
+ PlotLabel *label(PlotAxisID id) { return axisLabel_[id]; }
+
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
+- SigC::Signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
+- SigC::Signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_press();
++ sigc::signal3<void,int,int,GdkEventButton*> signal_plot_mouse_release();
++ sigc::signal3<void,int,int,GdkEventMotion*> signal_plot_mouse_move();
+
+ void set_selection(const Rectangle &r);
+ Rectangle get_selection() { return select_; }
+diff -ur plotmm-0.1.2-old/plotmm/scale.h plotmm-0.1.2/plotmm/scale.h
+--- plotmm-0.1.2-old/plotmm/scale.h 2004-03-05 16:25:43.000000000 +0100
++++ plotmm-0.1.2/plotmm/scale.h 2008-07-25 00:25:30.000000000 +0200
+@@ -133,7 +133,7 @@
+ /*! This signal is thrown whenever the scale is enabled or disabled
+ * \sa set_enabled, enabled
+ */
+- SigC::Signal1<void,bool> signal_enabled;
++ sigc::signal1<void,bool> signal_enabled;
+
+ protected:
+ virtual void on_realize();
diff --git a/dev-cpp/plotmm/plotmm-0.1.2.ebuild b/dev-cpp/plotmm/plotmm-0.1.2.ebuild
index 3dea60e74..136607875 100644
--- a/dev-cpp/plotmm/plotmm-0.1.2.ebuild
+++ b/dev-cpp/plotmm/plotmm-0.1.2.ebuild
@@ -4,6 +4,8 @@
EAPI="1"
+inherit eutils
+
DESCRIPTION="Plot widget for GTKmm"
HOMEPAGE="http://plotmm.sourceforge.net/"
SRC_URI="mirror://sourceforge/plotmm/${P}.tar.gz"
@@ -18,12 +20,20 @@ RDEPEND=">=dev-cpp/gtkmm-2.0
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-libsigc++-2.2.patch"
+}
+
src_install() {
make install DESTDIR="${D}" || die "install failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README || die
if use doc; then
- dohtml -r doc/html/* || die "Dohtml failed"
+ dohtml -r doc/html/* || die "dohtml failed"
fi
}
+