summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-11-07 17:25:11 +0000
committerJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-11-07 17:25:11 +0000
commitef130902ca488c6eae0f84440d233be1d089f9a9 (patch)
treee9e2b5874f69eeb373082e1fab28bfe53bcc4a55
parentdev-python/pylibmc: Version bump (diff)
downloadsunrise-ef130902ca488c6eae0f84440d233be1d089f9a9.tar.gz
sunrise-ef130902ca488c6eae0f84440d233be1d089f9a9.tar.bz2
sunrise-ef130902ca488c6eae0f84440d233be1d089f9a9.zip
dev-python/pottymouth: Version bump and abi support
svn path=/sunrise/; revision=9481
-rw-r--r--dev-python/pottymouth/ChangeLog4
-rw-r--r--dev-python/pottymouth/Manifest6
-rw-r--r--dev-python/pottymouth/pottymouth-1.1.5.ebuild (renamed from dev-python/pottymouth/pottymouth-1.1.4.ebuild)11
3 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/pottymouth/ChangeLog b/dev-python/pottymouth/ChangeLog
index e7bc58db7..92cdf6fe1 100644
--- a/dev-python/pottymouth/ChangeLog
+++ b/dev-python/pottymouth/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 07 Nov 2009; Johan Bergström (jbergstroem) <bugs@bergstroem.nu>
+ -pottymouth-1.1.4.ebuild, +pottymouth-1.1.5.ebuild:
+ Version bump and abi support
+
22 Jun 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
pottymouth-1.1.4.ebuild:
Drop MY_PN, set MY_P directly
diff --git a/dev-python/pottymouth/Manifest b/dev-python/pottymouth/Manifest
index 0218e676c..98d9d84a3 100644
--- a/dev-python/pottymouth/Manifest
+++ b/dev-python/pottymouth/Manifest
@@ -1,4 +1,4 @@
-DIST PottyMouth-1.1.4.tar.gz 24691 RMD160 283b3cf11f00c0cb9fecfd5b57224629d4ea9035 SHA1 b3f1687bb26eb5209e66700f6de2af8f073e7b9c SHA256 a9b9a5586e667d07167b8b3b65fad06bdb111d84e90228643e6366b342e025d6
-EBUILD pottymouth-1.1.4.ebuild 587 RMD160 355658ac7d48584802b6419f2a850f225e0f4df5 SHA1 c382844b800c7a23fdc255e5a743b28569071a02 SHA256 9d5364341d4b3edd6f0540ae8ee612651ba2cc7111c4d33fa53fe3835e825d8e
-MISC ChangeLog 786 RMD160 a1816aaa1a122f088a4de4ca0cd01e65b8491781 SHA1 972480490176bace701a0362084c98ac04a1599b SHA256 5a145f0b9bfa0f117b8aca99ccb9ee5c6ba72d7cec0ac25e774024ba47024394
+DIST PottyMouth-1.1.5.tar.gz 25637 RMD160 d4c205734cd37661da35532643662f48a3bbcce1 SHA1 d355d50de4cea56b15bb7b20d0e7f7bfa146af5d SHA256 b5e905a190c2a1825aeda89199208d51ed63817c80880af78a76f84ddd7951c6
+EBUILD pottymouth-1.1.5.ebuild 592 RMD160 70a6e81947ec1d9aed36bd6f02aa22729c3dbc83 SHA1 5d0c2472992053288d85dfb0e5966e2f1f370e04 SHA256 758a26c68e6b2644dab9c0d429ff4a2a64731a090985fb2e41aaa98380c7b1b6
+MISC ChangeLog 939 RMD160 623c93f1165620732136f948fbbf42c728efbe65 SHA1 f7efdeb125f381cd8a5a1cd5ce952d4a062d854d SHA256 c8da7f54c9c3f9bb4514deccefbaf460f8b238a4a2e375c59ec24a3923cacc87
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pottymouth/pottymouth-1.1.4.ebuild b/dev-python/pottymouth/pottymouth-1.1.5.ebuild
index a8f28f06c..b76bbcffe 100644
--- a/dev-python/pottymouth/pottymouth-1.1.4.ebuild
+++ b/dev-python/pottymouth/pottymouth-1.1.5.ebuild
@@ -2,12 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+NEED_PYTHON=2.4
+SUPPORT_PYTHON_ABIS=1
+
inherit distutils
MY_P=PottyMouth-${PV}
DESCRIPTION="A python library that scrubs untrusted text to valid, nice-looking, completely safe XHTML"
HOMEPAGE="http://devsuki.com/pottymouth/"
-SRC_URI="http://devsuki.com/${PN}/dist/${MY_P}.tar.gz"
+SRC_URI="${HOMEPAGE}/dist/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -15,11 +18,11 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-python/setuptools"
-RDEPEND="dev-lang/python"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3*"
S=${WORKDIR}/${MY_P}
src_test() {
- distutils_python_version
- ${python} setup.py test || die "Tests failed"
+ ${python} test.py || die "Tests failed"
}