summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-01-25 00:47:24 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-01-25 00:47:24 +0000
commitf8df7bdb0160c217c87e2203c804ec902681f464 (patch)
tree4de07b7f6392cf6142e6f67985cccce06bd9c3dd
parentgames-arcade/openalchemist: Updating to EAPI 2 (diff)
downloadsunrise-f8df7bdb0160c217c87e2203c804ec902681f464.tar.gz
sunrise-f8df7bdb0160c217c87e2203c804ec902681f464.tar.bz2
sunrise-f8df7bdb0160c217c87e2203c804ec902681f464.zip
games-util/playonlinux: Updated ebuild 3.2.2 -> 3.3
svn path=/sunrise/; revision=7794
-rw-r--r--games-util/playonlinux/ChangeLog4
-rw-r--r--games-util/playonlinux/Manifest6
-rw-r--r--games-util/playonlinux/playonlinux-3.3.ebuild (renamed from games-util/playonlinux/playonlinux-3.2.2.ebuild)14
3 files changed, 14 insertions, 10 deletions
diff --git a/games-util/playonlinux/ChangeLog b/games-util/playonlinux/ChangeLog
index 6d80dd724..89c0fc143 100644
--- a/games-util/playonlinux/ChangeLog
+++ b/games-util/playonlinux/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Jan 2009; Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
+ -playonlinux-3.2.2.ebuild, +playonlinux-3.3.ebuild:
+ Updated ebuild 3.2.2 -> 3.3
+
09 Jan 2009; Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
-playonlinux-3.1.ebuild, +playonlinux-3.2.2.ebuild:
Version bump for playonlinux
diff --git a/games-util/playonlinux/Manifest b/games-util/playonlinux/Manifest
index 8191f3b73..34ff2e63e 100644
--- a/games-util/playonlinux/Manifest
+++ b/games-util/playonlinux/Manifest
@@ -1,4 +1,4 @@
-DIST PlayOnLinux_3.2.2.tar.gz 917953 RMD160 3bc33f87e1a8681356cc7c206024e92596ee82b1 SHA1 773043cfa0d4fc6bf483c2174498e966ccd146bd SHA256 657534aa5e12c8e7e27db1433fd717b2ceda1daec1773b9af9a37913e139c2d9
-EBUILD playonlinux-3.2.2.ebuild 2595 RMD160 b8ef03d5e9b9875d8a30a860e71708ea56016def SHA1 41d391a4b43cb9150436f749b86084935d637fdd SHA256 040fe82991342d99502f55f6d219842599b53f82b3a4655e7b88f334b22f8c8b
-MISC ChangeLog 1547 RMD160 fa7aff7baddbb740939165fcb3e1a724a10267dc SHA1 22ae2a6cf74f92e81af92c2b43f33d1941b32849 SHA256 45559cfcc73d0c6abf0e08e1058041e187106d989b3a4588cb6d48338fab9b37
+DIST PlayOnLinux_3.3.tar.gz 917971 RMD160 1f5ff41313344ad790b8f4141fdbf87418c66fd8 SHA1 caaa4fa14c70b1d6bf6cf47a2658e076f08e92ca SHA256 b2ce91127c278c5b2643faebdf14b5339d6d7f6ad955306c1dc02752a18ca056
+EBUILD playonlinux-3.3.ebuild 2532 RMD160 37a888d45ef1859389b5a69d73415ba3c9213552 SHA1 7a3471782cc8fe2cfc67121afaf5838c6a0270c2 SHA256 a9a207a365af8d8c314795d6df8b6b23ea2b47ebce8831f03cf44c46e0a854b9
+MISC ChangeLog 1699 RMD160 1797fb3e527e6331e30857aa9b97b802e4a807f0 SHA1 11be051ed9c7f4cab5ad763afcdb9d1a7c521a87 SHA256 ed8cf3492b0cd2b5687bf2b8107d21e970f476cabbb319deb275273b657159b1
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-util/playonlinux/playonlinux-3.2.2.ebuild b/games-util/playonlinux/playonlinux-3.3.ebuild
index ce79a39da..52b573a4e 100644
--- a/games-util/playonlinux/playonlinux-3.2.2.ebuild
+++ b/games-util/playonlinux/playonlinux-3.3.ebuild
@@ -3,11 +3,13 @@
# $Header: $
EAPI="1"
+
inherit eutils games
+MY_PN="PlayOnLinux"
DESCRIPTION="Set of scripts to easily configure wine for numerous Windows(tm) games."
HOMEPAGE="http://playonlinux.com/"
-SRC_URI="http://www.playonlinux.com/script_files/PlayOnLinux/${PV}/PlayOnLinux_${PV}.tar.gz"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -23,9 +25,7 @@ RDEPEND="dev-python/wxpython:2.8
app-arch/cabextract
x11-terms/xterm
app-emulation/wine
- media-gfx/imagemagick
- app-arch/lzma-utils"
-# lzma-utils is a run dep regarding playonlinux team
+ media-gfx/imagemagick"
S=${WORKDIR}/${PN}
@@ -33,8 +33,8 @@ src_install() {
# all things without exec permissions
insinto "${GAMES_DATADIR}/${PN}"
doins -r "${S}/themes" \
- "${S}/lang" "${S}/lib" \
- "${S}/etc" || die "installation failed"
+ "${S}/lang" "${S}/lib" \
+ "${S}/etc" || die "installation failed"
# bin/ install
exeinto "${GAMES_DATADIR}/${PN}/bin"
@@ -77,6 +77,6 @@ src_install() {
dodoc CHANGELOG || die "doc installation failed"
doicon "${S}/etc/${PN}.png"
- make_desktop_entry ${PN} "PlayOnLinux"
+ make_desktop_entry ${PN} ${MY_PN}
prepgamesdirs
}