summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2009-10-25 21:24:04 +0000
committerNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2009-10-25 21:24:04 +0000
commit457c9286c850381c71f23078e117ecf09d2069a0 (patch)
tree20b0803b59ba10337f2966b7b2610da01bdc5f27 /app-arch/lcab/lcab-1.0_beta12.ebuild
parentsci-libs/libgis: New ebuild for bug 290417 (split from sci-geosciences/aweather) (diff)
downloadsunrise-457c9286c850381c71f23078e117ecf09d2069a0.tar.gz
sunrise-457c9286c850381c71f23078e117ecf09d2069a0.tar.bz2
sunrise-457c9286c850381c71f23078e117ecf09d2069a0.zip
app-arch/lcab: New Ebuild for bug 236342, thanks to tommy[d]
svn path=/sunrise/; revision=9418
Diffstat (limited to 'app-arch/lcab/lcab-1.0_beta12.ebuild')
-rw-r--r--app-arch/lcab/lcab-1.0_beta12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/lcab/lcab-1.0_beta12.ebuild b/app-arch/lcab/lcab-1.0_beta12.ebuild
new file mode 100644
index 000000000..48752d7b4
--- /dev/null
+++ b/app-arch/lcab/lcab-1.0_beta12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI="2"
+
+inherit autotools
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="CAB file creation tool"
+HOMEPAGE="http://ohnopublishing.net/lcab/"
+SRC_URI="ftp://ohnopublishing.net/mirror/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s:1.0b11:${MY_PV}:" mytypes.h || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ doman ${PN}.1 || die
+ dodoc README || die
+}