summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-06-04 08:03:04 +0000
committerMichał Górny <mgorny@gentoo.org>2010-06-04 08:03:04 +0000
commit3d231571f157e5623f473f01db94b1eb71d34e6a (patch)
tree687b668dacb5b601f918f227bb6bb45a33bf3e6c /app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
parentapp-arch/zpaq: Use single sed for zpaqmake, use emake to compile executables.... (diff)
downloadsunrise-3d231571f157e5623f473f01db94b1eb71d34e6a.tar.gz
sunrise-3d231571f157e5623f473f01db94b1eb71d34e6a.tar.bz2
sunrise-3d231571f157e5623f473f01db94b1eb71d34e6a.zip
app-arch/zpaq-extras: Use emake to compile executables, explicitly specify the filename of profile taken from DISTDIR.
svn path=/sunrise/; revision=10642
Diffstat (limited to 'app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild')
-rw-r--r--app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
index 5fe547b8c..9743ec649 100644
--- a/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
+++ b/app-arch/zpaq-extras/zpaq-extras-0_p20100426.ebuild
@@ -22,24 +22,20 @@ DEPEND="app-arch/unzip"
RDEPEND=""
src_compile() {
- local _prog
-
- mkdir bin
- for _prog in bwtpre bwt_ jpeg_jo exe_jo; do
- "$(tc-getCXX)" ${CXXFLAGS} ${_prog}.cpp -o bin/${_prog} \
- || die "compiling ${_prog} failed"
- done
+ tc-export CXX
+ progs='bwtpre bwt_ jpeg_jo exe_jo'
+ emake ${progs} || die
sed \
-e 's:^pcomp zpaq r:pcomp /usr/bin/zpaq r/usr/share/zpaq/:' \
-e 's:^pcomp \([^/]\):pcomp /usr/libexec/zpaq/\1:' \
- -i *.cfg || die 'sed failed'
+ -i *.cfg || die
}
src_install() {
exeinto /usr/libexec/zpaq
- doexe bin/* || die 'dobin failed'
+ doexe ${progs} || die
insinto /usr/share/zpaq
- doins *.cfg "${DISTDIR}"/*.cfg || die 'doins failed'
+ doins *.cfg "${DISTDIR}"/fast.cfg || die
}