summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDrChandra <gentooperson@yahoo.com>2006-06-22 15:20:50 +0000
committerDrChandra <gentooperson@yahoo.com>2006-06-22 15:20:50 +0000
commite2ce5e2e5f13177f8dfee1d4407434126d3bce67 (patch)
tree0a5ad1362b7cb003377cbf20faf60cc1df6a3b0e /app-backup/keep/keep-0.3.0.ebuild
parentFix up repoman complaints (diff)
downloadsunrise-e2ce5e2e5f13177f8dfee1d4407434126d3bce67.tar.gz
sunrise-e2ce5e2e5f13177f8dfee1d4407434126d3bce67.tar.bz2
sunrise-e2ce5e2e5f13177f8dfee1d4407434126d3bce67.zip
New keep Ebuild for bug 135362 thanks to Mike Pagano
svn path=/sunrise/; revision=188
Diffstat (limited to 'app-backup/keep/keep-0.3.0.ebuild')
-rw-r--r--app-backup/keep/keep-0.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-backup/keep/keep-0.3.0.ebuild b/app-backup/keep/keep-0.3.0.ebuild
new file mode 100644
index 000000000..97d7d1249
--- /dev/null
+++ b/app-backup/keep/keep-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit kde
+need-kde 3.5.2
+
+DESCRIPTION="A simple backup system for KDE"
+HOMEPAGE="http://jr.falleri.free.fr/keep/wiki/Home"
+
+SRC_URI="http://jr.falleri.free.fr/files/devel/keep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-backup/rdiff-backup-1.0.1-r1"
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog INSTALL TODO AUTHORS README VERSION
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "After initial install the Keep daemon needs to be started "
+ ewarn "manually via KControl - Services. The Keep daemon will automatically "
+ ewarn "be loaded at the next KDE startup"
+ ewarn
+ ewarn "For details, please visit the homepage at ${HOMEPAGE}"
+ ewarn
+}