summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDainius Masiliūnas (GreatEmerald) <pastas4@gmail.com>2013-03-11 20:30:31 +0200
committerDainius Masiliūnas (GreatEmerald) <pastas4@gmail.com>2013-03-11 20:30:31 +0200
commit8c729915aab917ba3f7e39607cdf6e9e18b4ec44 (patch)
tree30f9f8b16e30d74b8f024bd89f0896fbcaa3b148 /app-backup
parentfix changelogs (diff)
downloadsunrise-8c729915aab917ba3f7e39607cdf6e9e18b4ec44.tar.gz
sunrise-8c729915aab917ba3f7e39607cdf6e9e18b4ec44.tar.bz2
sunrise-8c729915aab917ba3f7e39607cdf6e9e18b4ec44.zip
app-backup/snapper: New Ebuild for bug #446680
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/snapper/ChangeLog10
-rw-r--r--app-backup/snapper/Manifest3
-rw-r--r--app-backup/snapper/metadata.xml18
-rw-r--r--app-backup/snapper/snapper-9999.ebuild51
4 files changed, 82 insertions, 0 deletions
diff --git a/app-backup/snapper/ChangeLog b/app-backup/snapper/ChangeLog
new file mode 100644
index 000000000..c04c88d8a
--- /dev/null
+++ b/app-backup/snapper/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-backup/snapper
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*snapper-9999 (11 Mar 2013)
+
+ 11 Mar 2013; Dainius Masiliūnas (GreatEmerald) <pastas4@gmail.com>
+ +snapper-9999.ebuild, +metadata.xml:
+ New Ebuild for bug #446680
+
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
new file mode 100644
index 000000000..7f660779b
--- /dev/null
+++ b/app-backup/snapper/Manifest
@@ -0,0 +1,3 @@
+EBUILD snapper-9999.ebuild 1423 SHA256 4362e75bfe6d7bd67f728556c9360f9790c9d37eccdce4e2816ec486e68ec581 SHA512 7b4b9cfe6b681226b430a489092d7fff5993557c5dcc4369308cf8b965c7ca00e590b9adfd89286996882687319f8023f7f6894aa87a780291e4d173c71ba41a WHIRLPOOL bbc628f2f10df289000373c7bb75045756e723a48bd840a969e49ca194ade4026d15441d15629ff03b9a2db7eaa0073a578c015d7d694c0def4e4c7cc038b5f1
+MISC ChangeLog 287 SHA256 cc199316afdf38cbf99531d26106ad70b5ec82ddd73fa0646ae65230487c8ece SHA512 8052a1249c49fa8ebcbcf8c60e53cabedc45205aeb88518e375ab379b50ed253839c4cf8300175e0995182cde581a212e4da2cd6694976eea3cb06f688d38d56 WHIRLPOOL 6f5692a8de09be7f719cc322ed91a664b9049722733c98ff97ad12dafad2efd5396f8e3eba71af5db8a7f1394e1d275fee72e43fcd7925f78e2cca222175e084
+MISC metadata.xml 712 SHA256 ddc3132ea712f4ed5986ad7852c9f00fab1d53da0f673ac9d70780a462473a7f SHA512 cf0d87ff224b4c6556e099c400e5945e0794115289c3e51450f4373eb73a349c19de045be8c7da1ce1ccf6b6f7f249804d2bd63cfb8bea0351f0cf263c158c52 WHIRLPOOL c08dd2dc740a85762cddab2744fe5ea21e977307021ca05b71a66f20d2561441b2c0b61bd49fa890554592e3d55d4992e3f5d9fca58a90a30d5945cb28754734
diff --git a/app-backup/snapper/metadata.xml b/app-backup/snapper/metadata.xml
new file mode 100644
index 000000000..78a61706e
--- /dev/null
+++ b/app-backup/snapper/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Snapper is a command-line program for filesystem snapshot management.
+ It can create, delete and compare snapshots and undo changes done
+ between snapshots. It supports both btrfs and ext4.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>aschnell@suse.de</email>
+ <name>Arvin Schnell</name>
+ </maintainer>
+ <changelog>https://raw.github.com/openSUSE/snapper/master/package/snapper.changes</changelog>
+ <bugs-to>https://bugzilla.novell.com/</bugs-to>
+ <remote-id type="github">openSUSE/snapper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-backup/snapper/snapper-9999.ebuild b/app-backup/snapper/snapper-9999.ebuild
new file mode 100644
index 000000000..4cd6c1588
--- /dev/null
+++ b/app-backup/snapper/snapper-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools eutils git-2
+
+DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
+HOMEPAGE="http://snapper.io/"
+EGIT_REPO_URI="git://github.com/openSUSE/snapper.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-libs/boost
+ dev-libs/libxml2
+ sys-apps/dbus
+ sys-libs/zlib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # No configure file provided at the moment
+ eautoreconf
+}
+
+src_configure() {
+ # No YaST in Gentoo
+ econf --disable-zypp --with-conf="/etc/conf.d"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ nonfatal dodoc AUTHORS LIBVERSION VERSION package/snapper.changes
+ # Exising configuration file required to function
+ newconfd data/sysconfig.snapper snapper
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up at least one config"
+ elog "manually, or else the tool will get confused. Typically you should"
+ elog "create a '/.snapshots' directory, then copy the file"
+ elog "'/etc/snapper/config-templates/default' into '/etc/snapper/configs/',"
+ elog "rename the file to 'root', and add its name into '/etc/conf.d/snapper'."
+ elog "That will instruct Snapper to snapshot the root of the filesystem by"
+ elog "default. For more information, see the snapper(8) manual page."
+}