summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Cheng (raeLLL) <crquan@gmail.com>2008-04-20 01:18:45 +0000
committerDenis Cheng (raeLLL) <crquan@gmail.com>2008-04-20 01:18:45 +0000
commit2ad1d1178da43f21e186618f8e745686ade84628 (patch)
tree3119b3c07722201b095d4e1f8d034f0f9355a7ed /app-benchmarks/filebench/filebench-1.2.4.ebuild
parentsci-mathematics/dataplot: Move -I/usr/include/GL from `use gd` conditional to... (diff)
downloadsunrise-2ad1d1178da43f21e186618f8e745686ade84628.tar.gz
sunrise-2ad1d1178da43f21e186618f8e745686ade84628.tar.bz2
sunrise-2ad1d1178da43f21e186618f8e745686ade84628.zip
app-benchmarks/filebench: New ebuild for bug 218223
svn path=/sunrise/; revision=6072
Diffstat (limited to 'app-benchmarks/filebench/filebench-1.2.4.ebuild')
-rw-r--r--app-benchmarks/filebench/filebench-1.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-benchmarks/filebench/filebench-1.2.4.ebuild b/app-benchmarks/filebench/filebench-1.2.4.ebuild
new file mode 100644
index 000000000..9b30489bc
--- /dev/null
+++ b/app-benchmarks/filebench/filebench-1.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION="Filebench - A Model Based File System Workload Generator"
+HOMEPAGE="http://sourceforge.net/projects/filebench/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-devel/flex
+ sys-devel/bison"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/linux-port.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodoc README AUTHORS docs/README.benchpoint
+}