summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2006-07-31 14:32:33 +0000
committerJakub Moc <jakub@gentoo.org>2006-07-31 14:32:33 +0000
commitd1ea85a16ff0e0f3fad35e8979caf6f98f2e934c (patch)
tree17ca5d8a71ca82d7b06380bf295267ea0e64d8fd /app-cdr/cddetect/cddetect-2.0.ebuild
parentsci-visualization/grapher: Fix RDEPEND (diff)
downloadsunrise-d1ea85a16ff0e0f3fad35e8979caf6f98f2e934c.tar.gz
sunrise-d1ea85a16ff0e0f3fad35e8979caf6f98f2e934c.tar.bz2
sunrise-d1ea85a16ff0e0f3fad35e8979caf6f98f2e934c.zip
Move to app-cdr, fix CC
svn path=/sunrise/; revision=769
Diffstat (limited to 'app-cdr/cddetect/cddetect-2.0.ebuild')
-rw-r--r--app-cdr/cddetect/cddetect-2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-cdr/cddetect/cddetect-2.0.ebuild b/app-cdr/cddetect/cddetect-2.0.ebuild
new file mode 100644
index 000000000..f475dd4de
--- /dev/null
+++ b/app-cdr/cddetect/cddetect-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Detects CD/DVD types without mounting them"
+HOMEPAGE="http://www.bellut.net/projects.html#cddetect"
+SRC_URI="http://www.bellut.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '2d' \
+ -e "s:gcc:$(tc-getCC):" Makefile \
+ || die "sed failed in Makefile"
+}
+
+src_install() {
+ dobin ${PN}
+}