summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-06-18 23:56:24 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-06-18 23:56:24 +0000
commit12294e2f55c9c790745f8da43213d61e95c6ec13 (patch)
tree1890dbe94c601fcf3baa4a714b66a824b8110e48 /app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild
parentsloted qca from bug 129536 (diff)
downloadsunrise-12294e2f55c9c790745f8da43213d61e95c6ec13.tar.gz
sunrise-12294e2f55c9c790745f8da43213d61e95c6ec13.tar.bz2
sunrise-12294e2f55c9c790745f8da43213d61e95c6ec13.zip
all of the plugins for qca beta 2
svn path=/sunrise/; revision=129
Diffstat (limited to 'app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild')
-rw-r--r--app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild b/app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild
new file mode 100644
index 000000000..45a2ccb75
--- /dev/null
+++ b/app-crypt/qca-pkcs11/qca-pkcs11-0.1_p20060407.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils qt4
+
+MY_PV="${PV/_p/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Qt RSA PKCS11 plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/2.0/beta2/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+
+RDEPEND="$(qt_min_version 4.1.0)
+ >app-crypt/qca-1.99
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc-4.extra-qualification.patch
+}
+
+src_compile() {
+ QTDIR="/usr/lib" ./configure || die "configure failed"
+
+ qmake \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+ QMAKE_RPATH= \
+ QTDIR="/usr/lib" \
+ "CONFIG += no_fixpath release" \
+ ${PN}.pro \
+ || die "qmake failed"
+
+ # ugly workaround...
+ if ! built_with_use qt debug || ! use debug; then
+ sed -i -e 's/QtCore_debug/QtCore/g' Makefile
+ fi;
+
+ make || die "make failed"
+}
+
+src_install() {
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+}