summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@astralcloak.net>2012-04-09 20:04:12 +1000
committerMichael Palimaka <kensington@astralcloak.net>2012-04-09 20:04:12 +1000
commit5cf57c83c590177f4ec9df604917a8132a8781a5 (patch)
tree7f2ad97d3ad52883256954ab991b5ae7545baec3 /app-editors/hexer/hexer-0.1.7.ebuild
parentsys-process/ts: Version bump. Add blockers to fix bug #285276. Don't install ... (diff)
downloadsunrise-5cf57c83c590177f4ec9df604917a8132a8781a5.tar.gz
sunrise-5cf57c83c590177f4ec9df604917a8132a8781a5.tar.bz2
sunrise-5cf57c83c590177f4ec9df604917a8132a8781a5.zip
app-editors/hexer: Version bump. Respect build variables, add missing dep, install additional tool. Thanks to mgorny for review.
Diffstat (limited to 'app-editors/hexer/hexer-0.1.7.ebuild')
-rw-r--r--app-editors/hexer/hexer-0.1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-editors/hexer/hexer-0.1.7.ebuild b/app-editors/hexer/hexer-0.1.7.ebuild
new file mode 100644
index 000000000..d335a9f4e
--- /dev/null
+++ b/app-editors/hexer/hexer-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Hex editor with vi/ex-style user interface"
+HOMEPAGE="http://devel.ringlet.net/editors/hexer/"
+SRC_URI="http://devel.ringlet.net/editors/${PN}/${P}.tar.gz"
+
+LICENSE="hexer"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qa.patch
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ${PN} bin2c
+ doman ${PN}.1
+ dodoc CHANGES README
+}