summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2006-10-31 21:52:13 +0000
committerPeter Weller <welp@gentoo.org>2006-10-31 21:52:13 +0000
commit99f57f3bb79bcf02a471c5e40cead044b02b053e (patch)
tree8061d0b64f6654c9169deb114029127003e21b2b /app-editors/tea/tea-14.2.4.ebuild
parentdev-tcltk/tclx: New version tclx-8.4 that fixes bug 133099 in tclx-8.3.5 (diff)
downloadsunrise-99f57f3bb79bcf02a471c5e40cead044b02b053e.tar.gz
sunrise-99f57f3bb79bcf02a471c5e40cead044b02b053e.tar.bz2
sunrise-99f57f3bb79bcf02a471c5e40cead044b02b053e.zip
app-editors/tea: New Ebuild for bug #153602
svn path=/sunrise/; revision=1712
Diffstat (limited to 'app-editors/tea/tea-14.2.4.ebuild')
-rw-r--r--app-editors/tea/tea-14.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/tea/tea-14.2.4.ebuild b/app-editors/tea/tea-14.2.4.ebuild
new file mode 100644
index 000000000..af3adc174
--- /dev/null
+++ b/app-editors/tea/tea-14.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Small GTK+ text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ipv6 gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.2
+ >=app-text/aspell-0.50.5
+ gnome? ( >=x11-libs/gtksourceview-1.6.1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable ipv6 ) \
+ $(use_enable !gnome legacy ) \
+ || die "Configure failed! *gasp*!"
+}
+
+src_install() {
+ #yaarrrr! emake DESTDIR="${D}" install fails with sandbox error :'(
+ einstall || die "Install failed! *gasp*!"
+
+ insinto /usr/share/applications/
+ doins ${FILESDIR}/tea.desktop
+
+ insinto /usr/share/pixmaps/
+ doins ${FILESDIR}/tea.png
+}