summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-07-05 16:37:54 +0000
committerMichał Górny <mgorny@gentoo.org>2010-07-05 16:37:54 +0000
commit48a5651d848cb34f1cf78674f496d8c3f36eec48 (patch)
tree3501df2f136d92a6cca949c9bd79b2ab778a4fd5 /app-editors
parentmedia-sound/scala-bin: Update HOMEPAGE and SRC_URI, cleanup. (diff)
downloadsunrise-48a5651d848cb34f1cf78674f496d8c3f36eec48.tar.gz
sunrise-48a5651d848cb34f1cf78674f496d8c3f36eec48.tar.bz2
sunrise-48a5651d848cb34f1cf78674f496d8c3f36eec48.zip
app-editors/mined: Update SRC_URI, fix using CC, CFLAGS and disable stripping.
svn path=/sunrise/; revision=10900
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mined/ChangeLog4
-rw-r--r--app-editors/mined/Manifest4
-rw-r--r--app-editors/mined/mined-2000.16.ebuild20
3 files changed, 22 insertions, 6 deletions
diff --git a/app-editors/mined/ChangeLog b/app-editors/mined/ChangeLog
index 70bdd5133..7750f45e3 100644
--- a/app-editors/mined/ChangeLog
+++ b/app-editors/mined/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 02 Jul 2010; Michał Górny (sedzimir) <mgorny.3ehbo@mailnull.com>
+ mined-2000.16.ebuild:
+ Update SRC_URI, fix using CC, CFLAGS and disable stripping.
+
04 Mar 2010; g3om1 g3om1s@gmail.com +mined-2000.16.ebuild, +metadata.xml:
New ebuild for bug 307629
diff --git a/app-editors/mined/Manifest b/app-editors/mined/Manifest
index 277c8e26c..fb4aa0819 100644
--- a/app-editors/mined/Manifest
+++ b/app-editors/mined/Manifest
@@ -1,4 +1,4 @@
DIST mined-2000.16.tar.gz 4343928 RMD160 63f6627304f852d5f523739e9961350966e6a08a SHA1 e173861e392710615fd6eed943acf32790359466 SHA256 89dcf40367d742b749b093813e7c7ef62e043d7048a60cf6e1c4bc1d693e9b18
-EBUILD mined-2000.16.ebuild 386 RMD160 6d5ce3732a770066fa5fbe8e0f567e83bb0b1d77 SHA1 ddc1aa379c61518341dd0bf5157fd1576bef0ff8 SHA256 6c258a8d391174a7b0665ddc40b00b3897fdc1303c5296011ce72078115072f8
-MISC ChangeLog 223 RMD160 8d640eb587539716cf45d2afdd58942fa8b4a24b SHA1 74e90c9781a6559c8ca35eb0198fd83eaa1a180c SHA256 b93321755e09ab3b9ae594152ba3d075100b6886c5d6f8331cc5ca05b64b0fd4
+EBUILD mined-2000.16.ebuild 661 RMD160 adfdc230e4669bd3af5ec551bf164eb16cebf4f2 SHA1 495b0f27dbd9006b37f32199537ca186027c5aa5 SHA256 63e90f17a35ed57c677adcdb7b190376219b98ac8bc2479e9af843230d63d638
+MISC ChangeLog 379 RMD160 957548b5205e89bafc379f68d7381fd9cd2df85e SHA1 62694425d884faf460e7e797f5560328ef9ea430 SHA256 87be2d7715be2ebf38926b9182403a3b2a14d6d3a1caa5dbebb75a2934a7406e
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/app-editors/mined/mined-2000.16.ebuild b/app-editors/mined/mined-2000.16.ebuild
index 532c87c64..a490d7765 100644
--- a/app-editors/mined/mined-2000.16.ebuild
+++ b/app-editors/mined/mined-2000.16.ebuild
@@ -2,17 +2,29 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=2
-inherit base
+inherit base toolchain-funcs
DESCRIPTION="Text editor with extensive Unicode and CJK support"
HOMEPAGE="http://mined.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+SRC_URI="http://towo.net/mined/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DOCS=( "README" "CHANGES" )
+DOCS=( README CHANGES )
+
+src_prepare() {
+ default
+
+ # Disable stripping and supply the correct compiler
+ # we can't just pass CC as upstream uses it as a keyword-var
+ sed -i -e '/strip/d' -e "s/\$(CC)/$(tc-getCC)/" src/mkinclud.mak || die
+}
+
+src_compile() {
+ emake OPT="${CFLAGS}" || die
+}