summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 18:39:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-31 18:39:26 +0000
commit4ff5bd87b0c06fa9579471895562f05842e46a6a (patch)
tree2bae65130d5424729c09b9b11a842eb6ab05a1be /app-editors
parentgnome-extra/timer-applet: Fix py-compile idiom for automake-1.11.2 compatibil... (diff)
downloadsunrise-4ff5bd87b0c06fa9579471895562f05842e46a6a.tar.gz
sunrise-4ff5bd87b0c06fa9579471895562f05842e46a6a.tar.bz2
sunrise-4ff5bd87b0c06fa9579471895562f05842e46a6a.zip
app-editors/scribes: Simplify py-compile fix.
svn path=/sunrise/; revision=12622
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scribes/ChangeLog3
-rw-r--r--app-editors/scribes/Manifest4
-rw-r--r--app-editors/scribes/scribes-0.4.ebuild2
3 files changed, 6 insertions, 3 deletions
diff --git a/app-editors/scribes/ChangeLog b/app-editors/scribes/ChangeLog
index 0f292ba83..c266dd487 100644
--- a/app-editors/scribes/ChangeLog
+++ b/app-editors/scribes/ChangeLog
@@ -3,6 +3,9 @@
# $Header: $
31 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org> scribes-0.4.ebuild:
+ Simplify py-compile fix.
+
+ 31 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org> scribes-0.4.ebuild:
Fix py-compile idiom for automake-1.11.2 compatibility (bug #396585).
12 Oct 2011; Nathan Phillip Brink <binki@gentoo.org> scribes-0.4.ebuild:
diff --git a/app-editors/scribes/Manifest b/app-editors/scribes/Manifest
index 9c89174a2..0c4b4ecf1 100644
--- a/app-editors/scribes/Manifest
+++ b/app-editors/scribes/Manifest
@@ -1,6 +1,6 @@
AUX scribes-byte-compiling-plugins.patch 1532 RMD160 353b456a31b2bbad04fb3a661eb3a545af2bf698 SHA1 cd8ee09c631503803a56999b2f38cbff8789bd8e SHA256 02426f2d8e6f69e3fa15b5a2be2f3ff9c596146a435a1a822a4de97a89f1072e
AUX scribes-sandbox.patch 407 RMD160 157515e20c8a89a0d347e390e053210f70e98865 SHA1 45ab7796826c365320393427ec59b4b55536d446 SHA256 dd8faf1962a9537b2d8b5d282ceb03d878f3b9527c065e2114f0381e8d77ec82
DIST scribes-0.4-dev-build954.tar.bz2 1142342 RMD160 640e64ae14afff3da2573c7acdf29c895dae7cf4 SHA1 0089c967872db6c72893945ba790a489620b3fc1 SHA256 f4cb765d5690f7549eb0336ce23fd0648ba548b9a9e259876e5ee2c095a4b0f1
-EBUILD scribes-0.4.ebuild 1531 RMD160 13c950d8bd4a736867050eff8419d41ce96ae7c2 SHA1 e1f225f5988f2d362f4a0bdd28a02d1c80f5e023 SHA256 fa7073f46fbeaea2f9d4eeff2a4ae687265d4052a1675ecdfa43f4e4324f904d
-MISC ChangeLog 659 RMD160 72885391388bb11fee5ec46eca0e5edcbc3b2f4f SHA1 b94ebb85c5798fd3c09d19386ddd730f96e439c1 SHA256 086a56696ffcd365705704ff18750245db1149fca81c98e36e8fbb9eb3ce0f11
+EBUILD scribes-0.4.ebuild 1517 RMD160 f9b1aa685b5914d47c04d63c60abf987aad6f2c7 SHA1 bcf108d26c9bd68e9d07cd41cf53d8577540b954 SHA256 5754da6f3d2508cb199fe13f6ff7722f0c817bcb0dc15b36e1293819ba833588
+MISC ChangeLog 766 RMD160 981149a1c778070b528afdb8e30193eb26d90740 SHA1 50138c5ffbdb94a144686dad83d753dc36f1ad25 SHA256 2f8f237c29e5b3f84c4813f7ea74ae9a5c3dcc542a06e561d67b6e5886cb1673
MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/app-editors/scribes/scribes-0.4.ebuild b/app-editors/scribes/scribes-0.4.ebuild
index 72dda98d1..bf2004208 100644
--- a/app-editors/scribes/scribes-0.4.ebuild
+++ b/app-editors/scribes/scribes-0.4.ebuild
@@ -50,7 +50,7 @@ src_prepare() {
eautoreconf
# make py-compile useless (but true)
- echo -e '#!'$(type -P sh)'\n:' > py-compile || die "Could not kill py-compile"
+ echo '#!/bin/sh' > py-compile || die "Could not kill py-compile"
python_convert_shebangs -r 2 .