summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-09 18:31:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-09 18:31:27 +0000
commite929fc4b1f4c1770a500b12312a7a2d344b25c08 (patch)
tree32620ae709043e2a2bbeafa99147f140d326a1f2 /app-editors
parentgnome-extra/teatime: resolved: SRC_URI switched to mirror://debian, unresolve... (diff)
downloadsunrise-e929fc4b1f4c1770a500b12312a7a2d344b25c08.tar.gz
sunrise-e929fc4b1f4c1770a500b12312a7a2d344b25c08.tar.bz2
sunrise-e929fc4b1f4c1770a500b12312a7a2d344b25c08.zip
app-editors/gummi: Fixes for multiple Python ABIs
svn path=/sunrise/; revision=11102
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/ChangeLog6
-rw-r--r--app-editors/gummi/Manifest5
-rw-r--r--app-editors/gummi/gummi-0.4.8-r1.ebuild36
-rw-r--r--app-editors/gummi/gummi-0.4.8.ebuild11
4 files changed, 54 insertions, 4 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 8f4489b52..a4f7b569e 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*gummi-0.4.8-r1 (09 Aug 2010)
+
+ 09 Aug 2010; Justin Lecher <jlec@gentoo.org> gummi-0.4.8.ebuild,
+ +gummi-0.4.8-r1.ebuild:
+ Fixes for multiple Python ABIs
+
17 May 2010; Alexander van der Mey <alexvandermey@gmail.com>
-gummi-0.4.5.ebuild, +gummi-0.4.8.ebuild:
Version bump for Gummi, thanks to chithead & binki for review
diff --git a/app-editors/gummi/Manifest b/app-editors/gummi/Manifest
index d2920f191..c936c9070 100644
--- a/app-editors/gummi/Manifest
+++ b/app-editors/gummi/Manifest
@@ -1,4 +1,5 @@
DIST gummi-0.4.8.tar.gz 44807 RMD160 2b386155f7813b550c4b64b6afabc9e7f8fe5fb5 SHA1 82f869c7e7abab7ea166fa38f91d6bbaf56d11ea SHA256 a17f7abed74abe5b56e287268725a12ed0f02af02f2b567c6bebe4115b712015
-EBUILD gummi-0.4.8.ebuild 847 RMD160 e7132b3f4cb2b6a0b4e8de76e4ba00ba88a94383 SHA1 befc3de20598ee5368a78b67c71eca77413441eb SHA256 c0a5b37c1ac5ca14262f46a98f405237c1b23a01651cf216c8ea1df772d4db8d
-MISC ChangeLog 1832 RMD160 7edef3abbc4db7c249c32cf549038af37c020ffb SHA1 cef0c5bd5ea20d116d7671b68415334dc3ee7123 SHA256 77aab989ad366c44556faa6bff54434a92e6e5add28f1b527449413a1d446081
+EBUILD gummi-0.4.8-r1.ebuild 944 RMD160 cc29adba04c3a14c61156093c5e89e101f82079d SHA1 4bebd1c4272d5ae479b08a5f6cc0d16290c824fa SHA256 3e9e3c37c856aff7152c395d3eb5422cf7445cb00053ce0c2b139c0398de410a
+EBUILD gummi-0.4.8.ebuild 944 RMD160 cc29adba04c3a14c61156093c5e89e101f82079d SHA1 4bebd1c4272d5ae479b08a5f6cc0d16290c824fa SHA256 3e9e3c37c856aff7152c395d3eb5422cf7445cb00053ce0c2b139c0398de410a
+MISC ChangeLog 1990 RMD160 a2f6a6951a18989fca387efed8f197ac821c8b1d SHA1 04e3f1c41f4a6b082a253c078127f7080ccbd5f6 SHA256 a1ac4bcf4edf9776db7e0807d7ad565d06a0392c24b37bf46e268904f82d1e9f
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/app-editors/gummi/gummi-0.4.8-r1.ebuild b/app-editors/gummi/gummi-0.4.8-r1.ebuild
new file mode 100644
index 000000000..f37e66c99
--- /dev/null
+++ b/app-editors/gummi/gummi-0.4.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/redmine/attachments/download/25/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pygtksourceview-2.4.0:2
+ dev-python/python-poppler
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ x11-libs/gtk+:2
+ x11-libs/pango"
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell checking through gtkspell. You are"
+ elog "required to have dev-python/gtkspell-python installed to use this"
+ elog "feature. Support for additional languages can be enabled by"
+ elog "installing myspell-** packages for your language of choice."
+ distutils_pkg_postinst
+}
diff --git a/app-editors/gummi/gummi-0.4.8.ebuild b/app-editors/gummi/gummi-0.4.8.ebuild
index a14c3839d..f37e66c99 100644
--- a/app-editors/gummi/gummi-0.4.8.ebuild
+++ b/app-editors/gummi/gummi-0.4.8.ebuild
@@ -2,7 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=1
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="Simple LaTeX editor for GTK+ users"
@@ -14,7 +19,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-python/pygtksourceview-2.4.0:2
+RDEPEND="
+ >=dev-python/pygtksourceview-2.4.0:2
dev-python/python-poppler
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
@@ -26,4 +32,5 @@ pkg_postinst() {
elog "required to have dev-python/gtkspell-python installed to use this"
elog "feature. Support for additional languages can be enabled by"
elog "installing myspell-** packages for your language of choice."
+ distutils_pkg_postinst
}