summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad A Simmons (CCIEChad) <chad.simmons@member.fsf.org>2008-09-03 19:38:10 +0000
committerChad A Simmons (CCIEChad) <chad.simmons@member.fsf.org>2008-09-03 19:38:10 +0000
commit88a6fee02ef926934c39c8ad0f437f3e11e82688 (patch)
tree82c42bc1fef01c192ab043c6ce7711a4af78fa88 /app-emulation/dynagen/dynagen-0.11.0.ebuild
parentnet-p2p/freenet: Use db-je:3.3 (diff)
downloadsunrise-88a6fee02ef926934c39c8ad0f437f3e11e82688.tar.gz
sunrise-88a6fee02ef926934c39c8ad0f437f3e11e82688.tar.bz2
sunrise-88a6fee02ef926934c39c8ad0f437f3e11e82688.zip
app-emulation/dynagen: New ebuild for bug 170013 thanks to Tommy for the review
svn path=/sunrise/; revision=6978
Diffstat (limited to 'app-emulation/dynagen/dynagen-0.11.0.ebuild')
-rw-r--r--app-emulation/dynagen/dynagen-0.11.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/dynagen/dynagen-0.11.0.ebuild b/app-emulation/dynagen/dynagen-0.11.0.ebuild
new file mode 100644
index 000000000..0eb1eba8c
--- /dev/null
+++ b/app-emulation/dynagen/dynagen-0.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python
+
+DESCRIPTION="Text-based frontend to Dynamips Cisco router emulator."
+HOMEPAGE="http://www.dynagen.org/"
+SRC_URI="mirror://sourceforge/dyna-gen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-emulation/dynamips"
+
+src_install() {
+ insinto $(python_get_sitedir)
+ doins *.py || die "python files install failed"
+
+ dobin ${PN} || die "failed install of /usr/bin/dynagen"
+
+ insinto /etc
+ doins ${PN}.ini || die "config file install failed"
+
+ insinto /usr/share/${PN}
+ doins configspec || die "failed configspec install"
+
+ dodoc README.txt
+
+ insinto /usr/share/doc/${P}
+ doins -r sample_labs
+ dohtml -r docs/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}