summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2009-11-15 21:56:27 +0000
committerJustin Riley <justin.t.riley@gmail.com>2009-11-15 21:56:27 +0000
commit82f25e82fb9efcf49ea5ed2f5002ea9e0486c0a7 (patch)
tree5b93cc3d24fa19b3af24f9e13d8184d9cfaeec15 /app-misc/gizmod
parentapp-editors/dhex: New application, see bug 121086. Thanks to Zero_Chaos, ohno... (diff)
downloadsunrise-82f25e82fb9efcf49ea5ed2f5002ea9e0486c0a7.tar.gz
sunrise-82f25e82fb9efcf49ea5ed2f5002ea9e0486c0a7.tar.bz2
sunrise-82f25e82fb9efcf49ea5ed2f5002ea9e0486c0a7.zip
app-misc/gizmod: New Ebuild for bug 134016, thanks to ak for initial ebuild and Tommy, ohnobikini, and dilfridge for review
svn path=/sunrise/; revision=9525
Diffstat (limited to 'app-misc/gizmod')
-rw-r--r--app-misc/gizmod/ChangeLog4
-rw-r--r--app-misc/gizmod/Manifest4
-rw-r--r--app-misc/gizmod/gizmod-3.5.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/app-misc/gizmod/ChangeLog b/app-misc/gizmod/ChangeLog
index fc7bd32f1..9780f734f 100644
--- a/app-misc/gizmod/ChangeLog
+++ b/app-misc/gizmod/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Nov 2009; Justin Riley <justin.t.riley@gmail.com> +gizmod-3.5.ebuild:
+ New Ebuild for bug 134016, thanks to ak for initial ebuild and Tommy,
+ ohnobikini, and dilfridge for review
+
16 Mar 2009; Nick Fortino (nfortino) <nfortino@gmail.com>
gizmod-3.3.ebuild:
Update ebuild to use EAPI 2. Thanks to Cristian Ruppert and Thomas Sachau
diff --git a/app-misc/gizmod/Manifest b/app-misc/gizmod/Manifest
index e57486015..420797405 100644
--- a/app-misc/gizmod/Manifest
+++ b/app-misc/gizmod/Manifest
@@ -1,4 +1,6 @@
DIST gizmod-3.3.tar.bz2 336764 RMD160 9eb4e7e37060a52b3fdbd834ebab336fe671f939 SHA1 63c14754a9634a4e9e3210a029478e7c430e0654 SHA256 2dd2fc7d1125adedcbe6723ce82ee5fb120ae2b35cf09691ca22711335cdddde
+DIST gizmod-3.5.tar.bz2 115721 RMD160 90bf061e759713cf24629016443fba09eb00131d SHA1 baecf3b493a43836586fbb91001c6e79bd933a18 SHA256 63c7620e14a43719be0302f44597ca6c38f263de1672b9bb58da63db48d6ecef
EBUILD gizmod-3.3.ebuild 779 RMD160 0ff2734dbba2e1ae9882167a3f55e8dfa0bb729d SHA1 646da6734ddfe04912a71b104eeac0b1481546f8 SHA256 147e6c8147ea1cf3bf2b0fff0b53a774014a69f4a7f1b8a249aeb5435737c9af
-MISC ChangeLog 1236 RMD160 d0d74083845dbbb743e36ee0f3a23f9f2b951fe8 SHA1 21fa9f0a984bee7aa67fc4f2a9f79f95379a9616 SHA256 19c7c8bb0ae326ae2cf9049520bfa4321822edf4cfcc03453267343e4ef47fb6
+EBUILD gizmod-3.5.ebuild 1991 RMD160 7bcb7287913f5d7fdff3a00f04a7943593d1f4a2 SHA1 3b6ad2a2375367936cc683f5d9cee5eda327f515 SHA256 2345c347e43d51368d0b0ba11563cc41afb9530891c3e4af8f457c98f79c8b53
+MISC ChangeLog 1423 RMD160 e06fe4a7c13adb83745d5757bc5b49e5e5d63a89 SHA1 3371f284dea3c058ec58159e8dd8cd962ef50c1b SHA256 584893ee3d9f01037c66b100e50b6842c9145386b4e6077f881d3e30559d222c
MISC metadata.xml 277 RMD160 d54adef29a37b47ca08b2194f5e6ebd0f668f4cf SHA1 caca608e4c20dfe264ebad8228ab8294b1f54b02 SHA256 bdb7a5f3eb5a695584b91f703ceae716d54fbadb7d6a329539bb16aac30377fe
diff --git a/app-misc/gizmod/gizmod-3.5.ebuild b/app-misc/gizmod/gizmod-3.5.ebuild
new file mode 100644
index 000000000..e073e8da6
--- /dev/null
+++ b/app-misc/gizmod/gizmod-3.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit linux-info cmake-utils
+
+DESCRIPTION="Input event scripting utility that has special support for fancy keyboards, mice, USB dials and more"
+HOMEPAGE="http://gizmod.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libvisual"
+RDEPEND="x11-libs/libXext
+ >=dev-libs/boost-1.34[python]
+ amd64? ( >=dev-libs/boost-1.36[python] )
+ x11-libs/libICE
+ media-libs/alsa-lib
+ libvisual? ( >=media-libs/libvisual-0.4.0 )"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="INPUT_EVDEV INOTIFY INOTIFY_USER"
+
+ERROR_INPUT_EVDEV="
+Gizmo Daemon needs input evdev support from the kernel.
+Please select \"Event interface\" (CONFIG_INPUT_EVDEV) under
+\"Device Drivers->Input Device Support->Event interface\".
+This option can be built directly into the kernel or as
+a module.
+"
+
+ERROR_INOTIFY="
+Gizmo Daemon needs inotify support built into the kernel.
+Please select \"Inotify file change notifification\"
+(CONFIG_INOTIFY) under \"Device Drivers->File systems\". This
+option can only be built directly into the kernel.
+"
+
+ERROR_INOTIFY_USER="
+Gizmo Daemon needs userspace inotify support built into the kernel.
+Please select \"Inotify file change notifification\"
+(CONFIG_INOTIFY) followed by \"Inotify support for userspace\"
+(CONFIG_INOTIFY_USER) under \"Device Drivers->File systems\". These
+options can only be built directly into the kernel.
+"
+
+src_prepare() {
+ # straighten up the paths
+ sed -i CMakeLists.txt -e /DefineInstallationPaths/d || die "sed: removal of DefineInstallationPaths failed"
+ sed -i libGizmod/CMakeLists.txt -e 's:lib$:${LIB_INSTALL_DIR}:' || die "sed: replacing lib with LIB_INSTALL_DIR failed"
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DSYSCONF_INSTALL_DIR=/etc
+ -DLIB_INSTALL_DIR=/usr/$(get_libdir)
+ $(cmake-utils_use_build libvisual VIS_PLUGIN)
+ "
+ cmake-utils_src_configure
+}