summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Krueger (srebrodolskite) <Hannes.Krueger@gmail.com>2007-10-31 02:12:26 +0000
committerHannes Krueger (srebrodolskite) <Hannes.Krueger@gmail.com>2007-10-31 02:12:26 +0000
commit2a569b167f05f1477958bc4ff894e411b3d0b509 (patch)
tree277f1c61712a8d294b81090ded7e458d7b25e35c /app-misc/gpspoint/gpspoint-2.030521.ebuild
parentgames-fps/uhexen2: Fixed DESCRIPTION (diff)
downloadsunrise-2a569b167f05f1477958bc4ff894e411b3d0b509.tar.gz
sunrise-2a569b167f05f1477958bc4ff894e411b3d0b509.tar.bz2
sunrise-2a569b167f05f1477958bc4ff894e411b3d0b509.zip
app-misc/gpspoint: New Ebuild for bug 62464 thanks to Mike Smith, Charles Mauch
svn path=/sunrise/; revision=4924
Diffstat (limited to 'app-misc/gpspoint/gpspoint-2.030521.ebuild')
-rw-r--r--app-misc/gpspoint/gpspoint-2.030521.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/gpspoint/gpspoint-2.030521.ebuild b/app-misc/gpspoint/gpspoint-2.030521.ebuild
new file mode 100644
index 000000000..65cbd5262
--- /dev/null
+++ b/app-misc/gpspoint/gpspoint-2.030521.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A utility to transfer tracks, routes and waypoints to and from garmin GPS devices."
+HOMEPAGE="http://pc12-c714.uibk.ac.at/gpspoint/"
+SRC_URI="http://pc12-c714.uibk.ac.at/gpspoint/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/dialog"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installation failed"
+ dodoc AUTHORS COPYRIGHT INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "Be sure and set the GPSPORT environment variable in your shell"
+ elog "or in /etc/profile.env if your gps is connected to a serial port"
+ elog "other than /dev/ttyS0 (COM1)."
+ elog "Alternatively you can make a link from /dev/gps to e.g. /dev/ttyS0."
+ elog "gpspoints needs rw access on that device to work properly."
+ elog
+}