summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-12 17:53:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-12 17:53:38 +0000
commit22b977a9ef8a69a44ab7f2c2acb143c039d1a61d (patch)
tree6df9ad1a190009413fc8362e8818b386944c6e90 /app-misc/qbrew/qbrew-0.4.1.ebuild
parentapp-misc/japanese-vocabulary: Migrate to qt4-r2 eclass (diff)
downloadsunrise-22b977a9ef8a69a44ab7f2c2acb143c039d1a61d.tar.gz
sunrise-22b977a9ef8a69a44ab7f2c2acb143c039d1a61d.tar.bz2
sunrise-22b977a9ef8a69a44ab7f2c2acb143c039d1a61d.zip
app-misc/qbrew: Migrate to qt4-r2 eclass
svn path=/sunrise/; revision=9853
Diffstat (limited to 'app-misc/qbrew/qbrew-0.4.1.ebuild')
-rw-r--r--app-misc/qbrew/qbrew-0.4.1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-misc/qbrew/qbrew-0.4.1.ebuild b/app-misc/qbrew/qbrew-0.4.1.ebuild
index 6158f451a..7160f25e8 100644
--- a/app-misc/qbrew/qbrew-0.4.1.ebuild
+++ b/app-misc/qbrew/qbrew-0.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="1"
-inherit qt4 multilib
+EAPI="2"
+inherit qt4-r2 multilib
DESCRIPTION="Homebrewer's recipe calculator"
HOMEPAGE="http://www.usermode.org/code.html"
@@ -14,15 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="|| ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 ) >=x11-libs/qt-4.3:4 )"
+DEPEND="x11-libs/qt-gui:4"
RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
export BINDIR="/usr/bin" DATADIR="/usr/share/${PN}" DOCDIR="/usr/share/doc/${P}"
./configure --qtdir="/usr/$(get_libdir)/qt4" || die "configure failed"
echo "QT += xml" >> qbrew.pro
eqmake4
- emake || die "emake failed"
}
src_install() {