summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-08-24 22:34:04 +0000
committerMichał Górny <mgorny@gentoo.org>2010-08-24 22:34:04 +0000
commit6bd1cecb8f349a5c029a3e9e2f45f2963ce0ad02 (patch)
tree2a5c2ff3deefbddd50e33a392221fde26a302233 /app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild
parentdev-util/reviewboard: Fix Djblets dependency (diff)
downloadsunrise-6bd1cecb8f349a5c029a3e9e2f45f2963ce0ad02.tar.gz
sunrise-6bd1cecb8f349a5c029a3e9e2f45f2963ce0ad02.tar.bz2
sunrise-6bd1cecb8f349a5c029a3e9e2f45f2963ce0ad02.zip
app-portage/smart-live-rebuild: Version bump.
(Portage version: 2.2_rc69/git/Linux x86_64, unsigned Manifest commit) svn path=/sunrise/; revision=11240
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild
new file mode 100644
index 000000000..3095bffdf
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PYTHON_DEPEND=*
+inherit python
+
+DESCRIPTION="Update live packages and emerge the modified ones"
+HOMEPAGE="http://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="http://github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ newbin ${PN}.py ${PN} || die
+ dodoc README sets.conf.example || die
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,} || die
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf || die
+}
+
+pkg_postinst() {
+ elog "You might also consider installing [dev-python/psutil] then, which is required"
+ elog "for ${PN} automatically detect if it was spawned by emerge."
+}