summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Neumann (Necoro) <gentoo@necoro.eu>2007-05-12 23:52:59 +0000
committerRené Neumann (Necoro) <gentoo@necoro.eu>2007-05-12 23:52:59 +0000
commit1b4c269e1d9061485b367f577bf45fbb780ee2d5 (patch)
tree929acb099d1ab1d4bcb1356d487e9230cd069836 /app-portage
parentdev-util/portatosourceview: New ebuild for bug #156545 (diff)
downloadsunrise-1b4c269e1d9061485b367f577bf45fbb780ee2d5.tar.gz
sunrise-1b4c269e1d9061485b367f577bf45fbb780ee2d5.tar.bz2
sunrise-1b4c269e1d9061485b367f577bf45fbb780ee2d5.zip
app-portage/portato: New ebuild for bug #156545
svn path=/sunrise/; revision=3615
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portato/ChangeLog8
-rw-r--r--app-portage/portato/Manifest4
-rw-r--r--app-portage/portato/metadata.xml5
-rw-r--r--app-portage/portato/portato-0.7.3.ebuild131
4 files changed, 148 insertions, 0 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
new file mode 100644
index 000000000..a071f2636
--- /dev/null
+++ b/app-portage/portato/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-portage/portato
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 12 May 2007; René Neumann (Necoro) <necoro@necoro.net>
+ +portato-0.7.3.ebuild, +metadata.xml:
+ New ebuild for bug #156545
+
diff --git a/app-portage/portato/Manifest b/app-portage/portato/Manifest
new file mode 100644
index 000000000..f411a0187
--- /dev/null
+++ b/app-portage/portato/Manifest
@@ -0,0 +1,4 @@
+DIST portato-0.7.3.tar.gz 84112 RMD160 d9a0a185b7c5864bba6994632b9da2e87ae0dd62 SHA1 29e2f50a85c1eb43717a0d4e7051e263c48905cc SHA256 df990b59a3a81e0851b6aabe61ba3c393af02368e6917f5fb2de8ac9ad16b81b
+EBUILD portato-0.7.3.ebuild 2802 RMD160 de4c8e1dcaffc3720fe00f68df2c5535f77a76cd SHA1 4d250daaee3799863bd75981310e79c2a0a4878c SHA256 8c6835caff7146bb17c6f603491c31a65f61e6bff7b0f0ae4604501679eaac7d
+MISC ChangeLog 248 RMD160 d690f178ec00a9d3457e15986ad5fc8ac6e2d0ca SHA1 e67c2a19c8b1bbce92efed4a4a358f0c0d9bce9c SHA256 378130694fe00bf25dcb3a5205ef6991d295361f8d297d4477df09b44bda3054
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-portage/portato/metadata.xml b/app-portage/portato/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-portage/portato/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/app-portage/portato/portato-0.7.3.ebuild b/app-portage/portato/portato-0.7.3.ebuild
new file mode 100644
index 000000000..8ce470619
--- /dev/null
+++ b/app-portage/portato/portato-0.7.3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils distutils
+
+DESCRIPTION="A GUI for Portage written in Python."
+HOMEPAGE="http://portato.sourceforge.net/"
+SRC_URI="mirror://sourceforge/portato/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk qt4 syntax userpriv etcproposals"
+
+GTKDEPS=">=dev-python/pygtk-2.8.6
+ >=x11-libs/vte-0.12.2
+ >=gnome-base/libglade-2.5.1
+ !userpriv? ( >=x11-libs/gksu-2.0.0 )
+ syntax? (
+ >=dev-util/portatosourceview-2.16.0
+ )"
+
+RDEPEND="=sys-apps/portage-2.1.2*
+
+ gtk? ( ${GTKDEPS} )
+ qt4? (
+ =dev-python/PyQt4-4.1.1
+ !userpriv? ( >=kde-base/kdesu-3.5.5 )
+ )
+ !gtk? ( !qt4? ( ${GTKDEPS} ) )
+
+ etcproposals? ( >=app-portage/etcproposals-1.0 )"
+
+S="${WORKDIR}/${PN}"
+CONFIG_DIR="/etc/${PN}/"
+DATA_DIR="/usr/share/${PN}/"
+PLUGIN_DIR="${DATA_DIR}/plugins"
+ICON_DIR="${DATA_DIR}/icons"
+
+apply_sed ()
+{
+ cd ${S}/${PN}
+
+ frontends="["
+ std=""
+
+ if ( use gtk || ( ! use gtk && ! use qt4 ) ); then
+ frontends="$frontends\"gtk\""
+ std="gtk"
+ fi
+
+ if use qt4; then
+ frontends="$frontends, \"qt\""
+
+ if test -z $std; then
+ std="qt"
+ fi
+ fi
+
+ frontends="${frontends/\[, /[}]"
+
+ einfo "Building frontends: $frontends"
+
+ sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
+ -e "s;^\(CONFIG_DIR\s*=\s*\).*;\1\"${CONFIG_DIR}\";" \
+ -e "s;^\(DATA_DIR\s*=\s*\).*;\1\"${DATA_DIR}\";" \
+ -e "s;^\(ICON_DIR\s*=\s*\).*;\1\"${ICON_DIR}\";" \
+ -e "s;^\(PLUGIN_DIR\s*=\s*\).*;\1\"${PLUGIN_DIR}\";" \
+ -e "s;^\(FRONTENDS\s*=\s*\).*;\1$frontends;" \
+ -e "s;^\(STD_FRONTEND\s*=\s*\).*;\1\"$std\";" \
+ constants.py
+
+ cd ..
+ if use userpriv; then
+ for d in *.desktop; do
+ sed -i -e "s/\(gk\|kde\)su.*\(portato.*\)/\2/" $d
+ done
+ fi
+}
+
+pkg_setup ()
+{
+ if ( use gtk || ( ! use gtk && ! use qt4 ) ) && ! built_with_use x11-libs/vte python; then
+ echo
+ eerror "x11-libs/vte has not been built with python support."
+ eerror "Please re-emerge vte with the python use-flag enabled."
+ die "missing python flag for x11-libs/vte"
+ fi
+
+ if ! use gtk && ! use qt4 ; then
+ echo
+ einfo "You have not chosen a frontend. Defaulting to gtk."
+ fi
+}
+
+src_compile ()
+{
+ pushd "${S}/${PN}" > /dev/null
+ apply_sed || die "Applying sed-commands failed."
+ popd > /dev/null
+
+ distutils_src_compile
+}
+
+src_install ()
+{
+ dodir ${DATA_DIR}
+ distutils_src_install
+
+ newbin portato.py portato
+ dodoc doc/*
+
+ # config
+ insinto ${CONFIG_DIR}
+ doins etc/*
+
+ # plugins
+ insinto ${PLUGIN_DIR}
+ keepdir ${PLUGIN_DIR}
+
+ use userpriv && doins "plugins/noroot.xml"
+ use etcproposals && doins "plugins/etc_proposals.xml"
+
+ # icon
+ doicon icons/portato-icon.png
+
+ # menus
+ ( use gtk || ( ! use gtk && ! use qt4 ) ) && domenu portato_gtk.desktop
+ use qt4 && domenu portato_qt.desktop
+}