summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-05-25 15:22:08 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-05-25 15:22:08 +0000
commit7e851b0f6786db0908ea8a946f9419da5301d485 (patch)
tree681715f4998266828c98562433dd965c24a484bc /app-portage
parentapp-antivirus/xfprot: quotations (diff)
downloadsunrise-7e851b0f6786db0908ea8a946f9419da5301d485.tar.gz
sunrise-7e851b0f6786db0908ea8a946f9419da5301d485.tar.bz2
sunrise-7e851b0f6786db0908ea8a946f9419da5301d485.zip
app-portage/portato: coding style improvement
svn path=/sunrise/; revision=3740
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portato/ChangeLog3
-rw-r--r--app-portage/portato/Manifest4
-rw-r--r--app-portage/portato/portato-0.7.3.ebuild44
3 files changed, 24 insertions, 27 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
index a071f2636..d50ff3c9a 100644
--- a/app-portage/portato/ChangeLog
+++ b/app-portage/portato/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 May 2007; Markus Ullmann <jokey@gentoo.org> portato-0.7.3.ebuild:
+ coding style improvement
+
12 May 2007; René Neumann (Necoro) <necoro@necoro.net>
+portato-0.7.3.ebuild, +metadata.xml:
New ebuild for bug #156545
diff --git a/app-portage/portato/Manifest b/app-portage/portato/Manifest
index f411a0187..6277a73bb 100644
--- a/app-portage/portato/Manifest
+++ b/app-portage/portato/Manifest
@@ -1,4 +1,4 @@
DIST portato-0.7.3.tar.gz 84112 RMD160 d9a0a185b7c5864bba6994632b9da2e87ae0dd62 SHA1 29e2f50a85c1eb43717a0d4e7051e263c48905cc SHA256 df990b59a3a81e0851b6aabe61ba3c393af02368e6917f5fb2de8ac9ad16b81b
-EBUILD portato-0.7.3.ebuild 2802 RMD160 de4c8e1dcaffc3720fe00f68df2c5535f77a76cd SHA1 4d250daaee3799863bd75981310e79c2a0a4878c SHA256 8c6835caff7146bb17c6f603491c31a65f61e6bff7b0f0ae4604501679eaac7d
-MISC ChangeLog 248 RMD160 d690f178ec00a9d3457e15986ad5fc8ac6e2d0ca SHA1 e67c2a19c8b1bbce92efed4a4a358f0c0d9bce9c SHA256 378130694fe00bf25dcb3a5205ef6991d295361f8d297d4477df09b44bda3054
+EBUILD portato-0.7.3.ebuild 2777 RMD160 53caf97af79eefe04670c39dfd8ca3f86fecdaa5 SHA1 e9bb75daa9a62bce0a93dbbaed84375e037eb1d8 SHA256 eaed98f95fbed99cb4f5a58196d6e17257258c0e850fdf5d0983ca9c91ccc436
+MISC ChangeLog 347 RMD160 765527ae9018ca84f0a91927a612cb95c798138c SHA1 a1872c5d8f74a4817a5de2687e08ab0c9adf5887 SHA256 408c8a8751b7383ad51f5027618a1cfc13bf7dbb560af5397546d522aff8a9db
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-portage/portato/portato-0.7.3.ebuild b/app-portage/portato/portato-0.7.3.ebuild
index 8ce470619..ecda3a76e 100644
--- a/app-portage/portato/portato-0.7.3.ebuild
+++ b/app-portage/portato/portato-0.7.3.ebuild
@@ -14,23 +14,21 @@ KEYWORDS="~x86 ~amd64"
IUSE="gtk qt4 syntax userpriv etcproposals"
GTKDEPS=">=dev-python/pygtk-2.8.6
- >=x11-libs/vte-0.12.2
- >=gnome-base/libglade-2.5.1
- !userpriv? ( >=x11-libs/gksu-2.0.0 )
- syntax? (
- >=dev-util/portatosourceview-2.16.0
- )"
+ >=x11-libs/vte-0.12.2
+ >=gnome-base/libglade-2.5.1
+ !userpriv? ( >=x11-libs/gksu-2.0.0 )
+ syntax? (
+ >=dev-util/portatosourceview-2.16.0
+ )"
RDEPEND="=sys-apps/portage-2.1.2*
-
- gtk? ( ${GTKDEPS} )
- qt4? (
- =dev-python/PyQt4-4.1.1
- !userpriv? ( >=kde-base/kdesu-3.5.5 )
- )
- !gtk? ( !qt4? ( ${GTKDEPS} ) )
-
- etcproposals? ( >=app-portage/etcproposals-1.0 )"
+ gtk? ( ${GTKDEPS} )
+ qt4? (
+ =dev-python/PyQt4-4.1.1
+ !userpriv? ( >=kde-base/kdesu-3.5.5 )
+ )
+ !gtk? ( !qt4? ( ${GTKDEPS} ) )
+ etcproposals? ( >=app-portage/etcproposals-1.0 )"
S="${WORKDIR}/${PN}"
CONFIG_DIR="/etc/${PN}/"
@@ -38,9 +36,8 @@ DATA_DIR="/usr/share/${PN}/"
PLUGIN_DIR="${DATA_DIR}/plugins"
ICON_DIR="${DATA_DIR}/icons"
-apply_sed ()
-{
- cd ${S}/${PN}
+apply_sed() {
+ cd "${S}"/${PN}
frontends="["
std=""
@@ -62,7 +59,7 @@ apply_sed ()
einfo "Building frontends: $frontends"
- sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
+ sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
-e "s;^\(CONFIG_DIR\s*=\s*\).*;\1\"${CONFIG_DIR}\";" \
-e "s;^\(DATA_DIR\s*=\s*\).*;\1\"${DATA_DIR}\";" \
-e "s;^\(ICON_DIR\s*=\s*\).*;\1\"${ICON_DIR}\";" \
@@ -79,8 +76,7 @@ apply_sed ()
fi
}
-pkg_setup ()
-{
+pkg_setup() {
if ( use gtk || ( ! use gtk && ! use qt4 ) ) && ! built_with_use x11-libs/vte python; then
echo
eerror "x11-libs/vte has not been built with python support."
@@ -94,8 +90,7 @@ pkg_setup ()
fi
}
-src_compile ()
-{
+src_compile() {
pushd "${S}/${PN}" > /dev/null
apply_sed || die "Applying sed-commands failed."
popd > /dev/null
@@ -103,8 +98,7 @@ src_compile ()
distutils_src_compile
}
-src_install ()
-{
+src_install() {
dodir ${DATA_DIR}
distutils_src_install