summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Szymaniak <lazy_bum@o2.pl>2011-06-26 13:56:31 +0000
committerPiotr Szymaniak <lazy_bum@o2.pl>2011-06-26 13:56:31 +0000
commit3573e1d051a5e5ded59015faaf0dbae18bfaa816 (patch)
tree1fa0309fb4240e2b0bf39a079ec8d71a14099c53 /app-text/docfrac/docfrac-3.1.5.ebuild
parentdev-libs/librets: New ebuild for bug 371707 thanks to mgorny for the review. (diff)
downloadsunrise-3573e1d051a5e5ded59015faaf0dbae18bfaa816.tar.gz
sunrise-3573e1d051a5e5ded59015faaf0dbae18bfaa816.tar.bz2
sunrise-3573e1d051a5e5ded59015faaf0dbae18bfaa816.zip
Added gcc-4.6 patch, moved to EAPI=4, lots of other small fixes.
svn path=/sunrise/; revision=12159
Diffstat (limited to 'app-text/docfrac/docfrac-3.1.5.ebuild')
-rw-r--r--app-text/docfrac/docfrac-3.1.5.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/app-text/docfrac/docfrac-3.1.5.ebuild b/app-text/docfrac/docfrac-3.1.5.ebuild
index fb7093f64..90a53ac2c 100644
--- a/app-text/docfrac/docfrac-3.1.5.ebuild
+++ b/app-text/docfrac/docfrac-3.1.5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit toolchain-funcs
+EAPI=4
+
+inherit eutils toolchain-funcs
DESCRIPTION="rtf/html/text conversion utility"
HOMEPAGE="http://docfrac.sourceforge.net/"
@@ -13,30 +15,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i \
-e "/CPPFLAGS=/s:-.*::" \
-e "s:ar -:$(tc-getAR) -:" \
- -e "s:g++ -:$(tc-getCXX) -:g" Makefile \
- || die "sed failed in Makefile"
-}
+ -e "s:g++ -:$(tc-getCXX) -:g" \
+ Makefile || die "sed failed in Makefile"
-src_compile() {
- make docfrac || die "emake failed"
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
}
-src_test() {
- make testhtml testtxt test || die "some tests failed"
+src_compile() {
+ emake ${PN}
}
src_install() {
# manual install because Makefile doesn't respect DESTDIR
- dobin docfrac
- doman doc/docfrac.1
+ dobin ${PN}
+ doman doc/${PN}.1
}