summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-06-19 09:14:51 +0000
committerAli Polatel <hawking@gentoo.org>2007-06-19 09:14:51 +0000
commit5d92555c98f7d8f419ba325ad617dfa8963cc58b (patch)
tree10131f87f8f8fc42a90c2e8b54c101628575d3fe /app-text/docfrac/docfrac-3.1.5.ebuild
parentdev-util/replimenu: New Ebuild for bug 130815. (diff)
downloadsunrise-5d92555c98f7d8f419ba325ad617dfa8963cc58b.tar.gz
sunrise-5d92555c98f7d8f419ba325ad617dfa8963cc58b.tar.bz2
sunrise-5d92555c98f7d8f419ba325ad617dfa8963cc58b.zip
app-text/docfrac: version bump
svn path=/sunrise/; revision=3972
Diffstat (limited to 'app-text/docfrac/docfrac-3.1.5.ebuild')
-rw-r--r--app-text/docfrac/docfrac-3.1.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/docfrac/docfrac-3.1.5.ebuild b/app-text/docfrac/docfrac-3.1.5.ebuild
new file mode 100644
index 000000000..d93fa9051
--- /dev/null
+++ b/app-text/docfrac/docfrac-3.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="rtf/html/text conversion utility"
+HOMEPAGE="http://docfrac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/CPPFLAGS=/s:-.*::" \
+ -e "s:ar -:$(tc-getAR) -:" \
+ -e "s:g++ -:$(tc-getCXX) -:g" Makefile \
+ || die "sed failed in Makefile"
+}
+
+src_compile() {
+ make docfrac || die "emake failed"
+}
+
+src_test() {
+ make testhtml testtxt test || die "some tests failed"
+}
+
+src_install() {
+ # manual install because Makefile doesn't respect DESTDIR
+ dobin docfrac
+ doman doc/docfrac.1
+}