summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2007-09-19 01:12:16 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2007-09-19 01:12:16 +0000
commit79781dfa4f3aaf7ab32042af17c4da5de96b05ef (patch)
tree90a9e9dae7782eb34e04b1d0f091f22292b488b9 /app-text/unac/unac-1.8.0.ebuild
parentgames-fps/uhexen2-cvs: Version bump (diff)
downloadsunrise-79781dfa4f3aaf7ab32042af17c4da5de96b05ef.tar.gz
sunrise-79781dfa4f3aaf7ab32042af17c4da5de96b05ef.tar.bz2
sunrise-79781dfa4f3aaf7ab32042af17c4da5de96b05ef.zip
app-text/unac: New ebuild for bug 134732. Thanks to Vieri <rentorbuy@yahoo.com>
svn path=/sunrise/; revision=4680
Diffstat (limited to 'app-text/unac/unac-1.8.0.ebuild')
-rw-r--r--app-text/unac/unac-1.8.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/unac/unac-1.8.0.ebuild b/app-text/unac/unac-1.8.0.ebuild
new file mode 100644
index 000000000..39a5649d0
--- /dev/null
+++ b/app-text/unac/unac-1.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="unac is a C library and a command line tool that removes accents from characters."
+HOMEPAGE="http://www.senga.org/"
+SRC_URI="mirror://debian/pool/main/u/unac/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/libiconv"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}.orig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # otherwise automake will fail
+ touch config.rpath
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ doman unaccent.1 unac.3
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Examples of using unaccent from the command line:"
+ einfo "unaccent utf8 été"
+ einfo "echo -e '\\\\0303\\\\0251t\\\\0303\\\\0251' | unaccent utf8"
+ einfo "unaccent ISO-8859-1 < myfile > myfile.unaccent"
+ einfo
+ einfo "man unaccent and man unac for more information."
+}