summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin von Gagern (MvG) <Martin.vGagern@gmx.net>2009-03-09 22:18:47 +0000
committerMartin von Gagern (MvG) <Martin.vGagern@gmx.net>2009-03-09 22:18:47 +0000
commit30380895a6a9197d0f8bb126406220cc5cc4297b (patch)
treec0299710c507dc2697b5265242a34e653b611317 /app-text/xmlroff/xmlroff-0.6.1.ebuild
parentdev-scheme/schemik: New Ebuild for bug 261206 (diff)
downloadsunrise-30380895a6a9197d0f8bb126406220cc5cc4297b.tar.gz
sunrise-30380895a6a9197d0f8bb126406220cc5cc4297b.tar.bz2
sunrise-30380895a6a9197d0f8bb126406220cc5cc4297b.zip
Initial xmlroff commit to sunrise. Bug #124339.
svn path=/sunrise/; revision=8040
Diffstat (limited to 'app-text/xmlroff/xmlroff-0.6.1.ebuild')
-rw-r--r--app-text/xmlroff/xmlroff-0.6.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/xmlroff/xmlroff-0.6.1.ebuild b/app-text/xmlroff/xmlroff-0.6.1.ebuild
new file mode 100644
index 000000000..9b29dcc69
--- /dev/null
+++ b/app-text/xmlroff/xmlroff-0.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A fast, free, high-quality, multi-platform XSL formatter"
+HOMEPAGE="http://xmlroff.org/"
+SRC_URI="http://xmlroff.org/download/${P}.tar.gz"
+
+LICENSE="sun-xmlroff"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+DEPEND=">=x11-libs/pango-1.6.0
+ >=media-libs/freetype-2.1.7
+ >=media-libs/fontconfig-2.2.0
+ >=dev-libs/glib-2.2.0
+ >=dev-libs/libxml2-2.6.7
+ >=dev-libs/libxslt-1.1.2
+ >=gnome-base/libgnomeprint-2.8.0
+ >=x11-libs/cairo-1.6.4-r1
+ x11-libs/gtk+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ einstall HTML_DIR="${D}/usr/share/doc/${P}" || die
+ if use doc; then
+ mv "${D}/usr/share/doc/${P}/${PN}" "${D}/usr/share/doc/${P}/html" || die
+ dodoc ChangeLog
+ else
+ rm -r "${D}/usr/share/doc/${P}/${PN}" || die
+ fi
+ dodoc AUTHORS NEWS README TODO
+}